486 desktop wont recognize compact flash hard drive.

edited April 2017 in Hardware
so, I recently disconnected all cards and cables from my machine, to get some good motherboard pictures.

However, now I am at the stage of putting everything back, and now, every time it boots up, it stops after the memory count, but if I disconnect the cable that goes to my hard drive, it passes, and then says to insert a system disk, which is expected.

Can anyone help me solve this problem? this computer cost me $200!.


  • This may cause by the 486 didn't support on LBA addressing, as for very old machine only support on CHS addressing HDD.

    And is your compact flash drive over 8GB? If yes, it is using LBA addressing, due to limitation of CHS, it is only support 8GB or below.
  • no it's 256mb, and it worked fine before I took everything out.
  • Make sure you use the exact slot that was used originally. My 486 does this too, the cable that the HDD plugs in to has 3 different slots and, while looking identical, using the slot that was used before by a different device causes the 486 to not recognize the disk.
  • I tried some more to resolve the problem, but I cannot, so I contacted a local computer repair shop, to see if they would be able to help, I am awaiting a response.

    Just because I can't do this myself, doesn't mean I am going to give up this easily.
  • Did you check that your IDE cable was connected with the proper polarity? Some IDE cables are not keyed.
    Make sure pin1 of IDE cable is connected to pin1 on the motherboard.
    Make sure pin1 of IDE cable is connected to pin1 on the HDD connector.

    Did you reconnect the floppy power connector to the HDD?
    Did you check the bios to see it the HDD is detected and set correctly?
    For the cost of a repair shop, you could buy a real 540mb ide drive on Ebay.
  • the bios does auto detect, but the problem is, that it won't detect it, at all, or at least that the systems just stops doing anything after the memory count. it just sits their displaying the memory count.
  • Does this CF card have the removable bit set? Many old systems don't like this on a firmware level, and some OSes will puke on a hardware level.
  • I'm not sure, but as I said, it was working fine before I removed everything.
  • Which makes it sound even more like a cabling issue. Odd boot problems can occur if an IDE cable is backwards, incorrect, shorted, broken, or the master/slave jumpers are wrong.

    So check, recheck, re-re-check, re-re-re-check and re-re-re-re-check the cables and jumpers. Also check if anything has gotten shorted underneath the motherboard.
  • yeah, I am trying that now, but it is extremely difficult to get the cables properly back into place.
  • SomeGuy wrote:
    or the master/slave jumpers are wrong.
    I've found that if you don't use a slave, jumpers aren't usually required, but that's with IDE drives. Using a CF card as a hard disk is totally new to me so your results may vary.
    SomeGuy wrote:
    Odd boot problems can occur if an IDE cable is backwards, incorrect
    I can attest to this. Really old IDE cables don't have that little notch to tell which way is up. Hook up a hard drive backwards and you get a disk failure error. Hook up a CD-ROM drive backwards and get a lot of BIOS error beeps with no output to the screen.

    Whenever I take apart a system or system component that I'm not familiar with, I try to draw a diagram of how it goes back together. This may help prevent this problem in the future.
  • Update:

    My father is going to help me,

    if that doesn't work, the repair shop I went to today told me to bring it in so they can have a look.

    I'm gonna do everything I can to get this back in order, as it costed me $200 and would be costly to replace, and also there don't seem to be many of these within my area.
Sign In or Register to comment.