A "problem" with GfxUI

For a while, when my system starts up (usually from a reboot), the following message appears (but soon vanishes afterwards):

Further looking at Event Viewer however, I see this:

Faulting application name: GfxUI.exe, version: 8.15.10.2182, time stamp: 0x4c44e324
Faulting module name: KERNELBASE.dll, version: 6.1.7601.24441, time stamp: 0x5cb935a7
Exception code: 0xe0434f4d
Fault offset: 0x000000000000bdfd
Faulting process id: 0x%9
Faulting application start time: 0x%10
Faulting application path: %11
Faulting module path: %12
Report Id: %13

Not sure how I can stop this from happening again each time the system reboots (or even when it starts up after a shutdown) although, everything else works and thankfully I don't see this often, as I usually just hibernate the system at the end of the day. I'm also suspecting that this may be connected to the WinLogon.exe problem I had back in August last year (where that caused a graphical fault). Is there anything I should do? Thanks.

Comments

  • Get a different graphics driver. Or reinstall it.
    Looks like some components of your current Intel HD don't like 7.

  • Excuse me... I've had this laptop for seven and a half years, and I've never had this error come up at me since then. Also, I went under Device Manager and saw that Intel HD Graphics is "working properly". It's not as if I've got a serious issue with my graphics driver though, otherwise the laptop would've been unusable.

  • Did Windows Update change your drivers recently? You should roll back to the previous version.

    Or maybe the latest W7 updates screwed something up...

    This reminds me of the last few years of NVIDIA drivers for Windows 2000, which were advertised as XP only because the control panel (which GfxUI is for Intel) wasn't compatible with 2000.

  • I don't wish to roll back the driver in case anything screws up badly, like what happened regarding an "update" to the sound driver years ago (in where rolling it back only caused the system to freeze up when the audio service tried to start, and had to go to Safe Mode to do some changes. It was a pain I tell you).

    Also, I did suspect that some of the updates may have something to do with it, but how would I found that out I wonder?

  • Don't roll back with the windows utility. Always uninstall, delete driver software and reinstall the working one. Unless you have 10, then it just reinstalls the broken one anyways.

    Gfxui is the control panel for your intel hd graphics driver. You can have the driver work, but not the panel.
    Just because it's worked for seven and a half years, doesn't mean it can't break. And obviously your computer is having things break. A .net update can break it (gfxui is .net based) or a driver update. And if there was a graphics driver malfunction, in order to prevent the computer from being unusable windows will revert to vgasave. My suggestion to completely uninstall and reinstall was a baseline method to see if a driver file change is at fault.

    But if you insist everything is perfect, you can remove gfxui from task scheduler.

    But what do I know? You have used that computer for 7+ years!

  • Like @yourepicfailure said, uninstall the drivers and reinstall them, at least to start with. Files can get corrupted or any number of things could be happening. If reinstalling the drivers doesn't work, that's an indication that the problem is elsewhere.

  • @yourepicfailure said:
    A .net update can break it (gfxui is .net based) or a driver update.

    I think that's my problem right there. In another thread, I mentioned of refusing future .NET Framework updates when I reported that they were affecting performance of this system and that I uninstalled them. The last one I have was from July 2018. So from this, do you really think I should obtain and install the latest .NET Framework update then?

    And as for removing it from Task Scheduler, I can't seem to find it under Active Tasks. What would it be under?

  • It's probably under startup items in msconfig (System Configuration).

  • You can use Autoruns. Extract and run "Autoruns.exe" (as and Administrator), then search for GfxUI (Or Intel HD Control Panel or something like that) and delete the entry by either pressing Ctrl+D or by simply Right clicking>Delete.

    AFAIK NET Framework can break some stuff pretty badly. I installed NET FX 4.8 on my Win7 PC and it semi broke VirtualBox 5.2.29, causing the entire program to be "classic themed" and simple actions like clicking on the VM's status bar icons crashed the program.

  • That's like when I had one .NET Framework update that completely wrecked access to Firefox and Internet Explorer, and also caused FrontPage 2003 to be unresponsive.

    I'm not sure about deleting that entry though, unless you tell me it's 100% safe to do so.

  • edited May 20

    It should be safe considering that it is just the control panel and not the driver itself. I used to do the same thing with the ATI control panel on my T41 with Windows 9x and 2000 (if I even selected it to install with the drivers).

  • Yeah, and kernelbase.dll in the error log points further to a .net malfunction as well.

  • It's hard to break your system using autoruns, unless you delete entries from codecs or so. IIRCC, your GfxUI entry should be in login tab, and it's 100,000% safe to delete this entry

    (You can use this tool to delete programs' entries that auto-start when you boot your computer, which can speed up the boot process)

  • Okay, I've got Autoruns up and I see four things that relate to that process. Under the Logon tab, there is "IgfxTray" which I think is related to GfxUI. Just want you all to confirm that it's the same thing before I do anything.

  • edited May 23

    Yeah that would be the system tray applet that would lead to the control panel (GfxUI) itself. You can disable that as it would be rendered redundant by the disabling of GfxUI.

    You'd probably have your boot time shortened by a few seconds as well.

  • That entry is for the Intel Control Panel or so. It's the app hat uses GfxUI, and it's pretty safe to delete it .

    f you are a bit frighten about deleting entries, you can simply uncheck it, that will prevent it from starting, and if it's the wrong entry, you can re-enable it by checking it again.

    You can try checking and unchecking certain entries to speed up a bit the boot process, until you find which entries are safe to uncheck.

  • I've unchecked the process, and I also deleted two other logon-based things too (such as BlueStacks and something to do with Journal Note Writer, and only did that due to "file not found" in each, and once saw errors to do with them under Event Viewer). However, after a reboot, I still got the same message so it isn't that one.

  • Hmmmm

    At this point either:
    Delete gfxui since it flat-out doesn't work.
    Or fix .Net. I believe for your hardware, gfx should use .net 3.x or 4.0. Uninstalling and reinstalling .net should "refresh" the broken components.

  • I'm sorry for not responding sooner but, I can't seem to delete "GfxUI", not from Autoruns anyway. Might be somewhere in the system folders where I can. Also, I thought that the next .NET update was for this month's Patch Tuesday but it wasn't so, if anybody can provide a link of the latest update (which I believe was the May 2019 one, I can't remmeber) then that would be grateful. I guess that may "reinstall" .NET in a way.

  • edited June 14

    Here's the May update. Download the one for your platform: http://www.catalog.update.microsoft.com/Search.aspx?q=KB4488669

    And here's the KB article if you like to read such things.

    Important

    A new version of this update was released on May 23, 2019. If you have downloaded and installed this update prior to this date, we recommend that you uninstall the previous version and then install the latest version of this update to avoid experiencing the issue described in the "Known Issues" section.

  • edited June 14

    Just when I was about to install it, I got this error message.

    Software Update KB4488669 Installation Wizard does not apply, or is blocked by another condition on your computer.

    And it was for both updates (the one for Windows 7 only, and another for it and Server 2008 R2).

    Strange... but it might be that I've turned off the .NET Framework itself a while back.

  • edited July 10

    I've then decided to install this month's .NET Framework update and, sad to say but it didn't solve the problem. I've subsequently uninstalled said update and now back to the July 2018 one. To be honest, I'm not really bothered by it now. As long as everything else works fine, then I'm happy.

  • Well, a miracle happened. Upon today's "Patch Tuesday" (well, "Wednesday" for me because I'm from the UK), I'm no longer getting that transitory error when the system starts up. Must be the latest security update had finally fixed it, and I had looked at Event Viewer to verify this. That's great news.

    But I'm still hibernating the system each time anyway. It's more preferable.

  • Nice to hear when Windows updates actually fix something instead of causing more headaches.

  • Actually, I think it may have been Startup Repair that fixed it, that came up from an unrelated issue that happened last month (where I uninstalled some updates that were no longer needed such as the Visual Basic platform, and also yet another problematic .NET update). That only came to mind right after I made my last post.

Sign In or Register to comment.