Solaris OpenStep, a rare gem worthy to be on winworldpc

Images and articles about Solaris OpenStep are all over the net, so to sum it up, NeXT and Sun joined forces to get Solaris off of CDE and use NeXT's desktop UI, and more importantly, its OPENSTEP framework to create cross platform applications. Sun moved focus to Java instead of OPENSTEP and kept the CDE desktop.

Over a decade later, the Retro community brought Solaris OpenStep back called LuBu OpenMagic!

I haven't actually tried it but the screenshot shows that the beautiful Sun Microsystems logo is replaced with a shrunken OPENSTEP logo like to what you see on the OPENSTEP Box or CD Cover:

So because of the removal of Sun logos, I don't want to use Lubu OpenMagic.

I want to use the original Solaris OpenStep. winworldpc doesn't have it (yet) so I tried looking for it and found this:

I tried using it, but when I try to uncompress them with their .sh script, it would fail. I also tried to uncompress each file manually but it would not uncompress. If anyone else knows where we can find a copy of Solaris OpenStep, or if anyone knows if this copy on actually can work, please reply! Thanks!


  • After deep diving into the matrix, I did some reading and discovered these .gz files are not .gz files at all. I validated that with the following command:

    $ file SUNWOosUc.cpio.bin.gz SUNWOosUc.cpio.bin.gz: ASCII cpio archive (SVR4 with no CRC)

    Its no wonder these files would not gunzip! They aren't gzipped in the first place! Why would the archiver even do that? renaming .cpio to .cpio.bin.gz...

    I honestly haven't heard of a .cpio file before. googling I found the following:

    Next, I opened and made the following change to the script on line 66 and added line 67:

    ## these files are not really gzipped. they are actually .cpio files in disguise. (cd $INSTALLPATH; gzcat $CURRENTDIR/$LIST | cpio -icdm)

    (cd $INSTALLPATH; cpio -idv < $CURRENTDIR/$LIST)

    And it successfully unarchived into a solaris_openstep directory! Next up, I'll tar the entire directory and get this file into Solaris running in QEMU. Wish me luck.

  • I um... must have messed up somewhere.. I mean... this is not what I was expecting. I dub thee.. CDE Openstep Stein Olaris...

    Can some Solaris OpenStep fan help me out? CDE is not suppose to be there all frankensteined with openstep. ARGH!!!

  • Almost no one used Solaris OpenSTEP, although I'm a solaris person. Try clicking the 'exit' button. CDE was the default DE of solaris from 2.6 to 9.

  • edited June 2019

    Thanks robobox.

    But I have a change of heart.

    As neat as this looks, this version I got from is incomplete without Interface Builder or Project Builder. Its basically more of a sample of the UI, but no means to make apps :neutral:

    Also, the OpenStep Terminal app is broken. Launching it does nothing.

    I guess you can think of this OpenStep 1.0 desktop environment for Solaris is some kind of trial version, or a user only version. It would be interesting to see if OpenStep apps with fat binaries would run in this thing though, but as it is right now, its too barebones for me.

    Looking at LuBu OpenMagic (enhanced Solaris OpenStep 1.1 sparc) seems to have alot more apps built in. But even that doesn't have Interface Builder or Project Builder as far as I know from looking at

    Would be nice to purchase on ebay some official boxed / CD release if that even exists. I believe it was a real product for sale from what I've read in archived articles. Would be interesing to see how does the CD, Box, etc look like. Or maybe it was an online only purchase... would be interesting to know that part of history.

    However I guess it really depends on what you want.

    For users who want to use OpenStep within CDE this is perfect "User Environment" to test a fat binary compiled from some some other OpenStep system. All they need to do is simply minimize that CDE control panel so that it doesn't get in the way of the OpenStep Dock.

    Fyi, I never explained how I got this working. I actually mirrored the manual install steps that did and it also works for this earlier version of OpenStep 1.0 with the caveat that you need to manually start it up within CDE with:

    $ sh /usr/openstep/bin/openstep

    And thats a wrap. Whoever is interested in following these steps described in this thread, good luck!

  • One last screenshot. I just had to try LuBu OpenMagic and the screenshot I found online was not 24bit color. So here it is in 24 bit color. Actually its quite impressive, and the install was easy. find it on github.

  • Does this run on Sparc hardware? I have a couple of Sun Sparcs lying around :)

  • @robbo007 said:
    Does this run on Sparc hardware? I have a couple of Sun Sparcs lying around :)

    Most likely does. All screenshots here are of QEMU SPARC, and Sun barely cared about x86 at the time.

  • Anybody know where to find Workshop OpenStep?
    (AKA Project Builder/Interface Builder for Solaris).

Sign In or Register to comment.