Compaq Armada 1700 touchpad cable and cap

Hello everyone,

I'm having a bit of a dilemma with a cable I'm unable to figure out what to do with it.

System board with troublesome CN16 cap and cable

I have no clue what to do with it. Tried pulling it from the cap, no go. Thinking it was a ZIF/LIF cable, I tried to pull it from the cap, nothing either. The manual mentions it is a ZIF cable though. I'm stuck at what to do, as I don't want to crap the system board because I pulled forcefully and wrecked the board.

Thank you in advance.


  • That's a rigid cable. First remove the electrical tape. It's good to remove that anyways as the rubber and adhesive can liquify with age. I say this as the tape is most likely forcing that cable down, making it hardwr to just come out on its own.

    That's a solid connector. I don't see where it would slide to lock/unlock. So try pulling with the little tab sticking out after removing the tape.

    When you're done, secure it like it was with new e tape.

Sign In or Register to comment.