Stupid Solaris 2.3-2.5.1 installation problems question

Sooo I've downloaded maybe every ISO of Solaris 2.3, 2.4, and 2.5.1 that I can find but I can't get any of them to boot either in QEMU or on real SPARCstation hardware (an SS5 and a Voyager).

I get some kind of issue around not being compatible with 2048 bytes (?) and/or "data transfer overrun".

Even though I am definitely not a Unix person, I am not totally green to this having successfully set up several QEMU and on real hardware installs of Solaris 2.6 completely fine.

Is there some issue with the other OS ISOs, or something else I'm missing here?

I know Sun had some kind of proprietary disk format thing called Volume Table of Content (VTOC) for their installers and I was wondering if that was the root cause?

Otherwise can anyone offer me real installer media from before 2.6 (ideally 2.3)?

The reason why I'm trying to do this is that Macintosh Application Environment 2.0 (which I have the original media for) kernel panics under Solaris 2.6 on both QEMU and real hardware, and I'd love to get it running!


  • Does QEMU officially support those versions of Solaris?

    Back when I messed with SunOS 4.1, I had to use TME (The Machine Emulator).

    Early SUN hardware used special CD-ROM drives and media that used 512 byte sectors. I'm not sure at what hardware level or OS version that stopped being the case.

    I have no idea if it is even possible to write CD-R/RW media what will work in those drives.
  • It's a bit hard to tell. Probably not. This only lists 1.1.2 and 2.6

    But this blog post indicated to me that maybe it runs a bunch more versions

    Yeah I'm aware of the 512 byte sector thing - I'm fairly sure my CD-ROM drive does support that. But I agree, I suspect that it may not be possible to create either ISOs or burn discs that work because of that or similar issue.

    I've been sent some further ISOs by some kind people on Twitter and am going to attempt with those.

    Failing that, I have genuine 2.5.1 media on its way to me...
  • Ah here we go, this would indicate the current QEMU version probably won't boot older Solaris "Please note that currently older Solaris kernels don’t work probably due to interface issues between OpenBIOS and Solaris."

    Sadly still doesn't quite explain the issue on real hardware but I'm 75% convinced its due to Sun's strange media format
  • It only ran on certain hardware. Did anyone dig up a HCL for that era?
  • edited February 2021
    Solaris 2.3-2.5.1 all ran on SPARC based hardware. I have a Sparcstation 5 and Sparcstation Voyager that I’ve tried with all the ISOs currently on WinWorld for download. The Solaris 2.6 ISO works fine but the others do not.

    I suspect a few different things could be the issue, not least of which is that Sun used to use a very particular format on their media, that either isn’t captured properly by the imaging process, or that these images have been adapted, or that it I don’t know how (or it isn’t possible) to write the media format correctly to a CD-R using a modern computer (I use MacOS).

    I would love to know the problem and the solution!
  • Chances are the images we have on Winworld are just "dd" dumps made under SunOS/Solaris. Which does make me wonder if it is possible to dd those to a hard drive, set the SCSI ID as what SunOS/Solaris expects for the CD drive and boot from that.

    It would be useful to know if Alchohol 120% or DIC+a Plextor drive could read and/or duplicate these disks.
  • That’s a good point. Maybe I could dd to a SCSI2SD partition. I’ll try that next
  • edited February 2021
    OK I am right in the middle of installing Solaris 2.3! Success!

    dd-ing an ISO to SCSI2SD totally worked. Fool me for trusting that MacOS would write an ISO to CD how I needed it to ha.

    Thank you for the help :smile:

    In case of use to anyone in future, here's what I did:
    1. dd the ISO to an SD card
    2. set up SCSI2SD where the first ~700MB are assigned to SCSI ID6 (Sun default CD-ROM address) - make sure set to 512 byte sectors (which might mean setting as a hard drive)
    3. An additional SCSI ID3 for the hard drive to install to - set to 2GB
    4. Installed!

    This video is very useful for anyone wanting to check SCSI2SD settings for Solaris and also having a hand-held run through of the entire Solaris 2.6 installation process via SCSI2SD:
Sign In or Register to comment.