BeOS 5.0 Professional Edition invalid file system

Hi, I was going to convert the IMG file for the BeOS 5.0 Professional download to an ISO for burning to a CD or even a VM but it seems that the file system is invalid on the img file? I am so confused. Can someone help?


  • You should just be able to rename the IMG to ISO and write it to a CD or mount it in a VM program. The image appears to contain ISO+Rock Ridge file systems.

  • You can't really: the problem is BeOS contains two data tracks, an ISO-9660 filesystem like normal, but that only contains some documents for booting the OS. The real meat is on track 2, which contains a BeFS partition with the OS. The problem is that almost all virtualization software and a lot of disc image tools only handle the single track. A cue sheet with a raw image is the only way to represent a BeOS CD.

    The workaround is to use a tool like bchunk to split the raw image into separate images with the cue sheet, and use the image on the second track.

  • Calvin, thanks for the workaround, I have added a note to the download.

  • Would anyone be so kind as to split the image for me? I've tried using bchunk to split the image, but sadly it doesn't work. I'd be super grateful if someone could provide a download link for a split image.

  • edited October 2021
    So I ran into this same mystery and worked it out. Sort of. I can generate isos but none of them want to work in my emulation setup.
    @MavZA , if you haven't lost hope, here you go.

    The trick is the included .ccd file *is not a .cue file* and therefore bchunk errors weirdly on it. There's a gnu tool called ccd2cue that I was able to build (on linux) that output this as the content of a .cue file:
    FILE "BeOS_5.0_Professional.img" BINARY
    TRACK 1 MODE1/2352
    INDEX 01 00:00:00
    TRACK 2 MODE1/2352
    INDEX 01 07:48:09
    TRACK 3 MODE1/2352
    INDEX 01 40:51:64
    Copy that into a beos.cue file and bchunk should work for ya.
Sign In or Register to comment.