newbie question

edited August 2004 in Software
i just tried out fedora core linux (my first distro) and when i tried to install a .sh file, i got the error "the script needs uudecode to run properly" i cant seem to find any way to fix this. is it an error caused by transfering something using binary when it should have been ASCII or something? *puts up acme flame-retardant umbrella* thanks for any help


  • Download this. and install it (I assume you know how to install a RPM) and try again.

  • "Congradulations ! Nessus is now installed on this host" thanks!
  • Sure!

  • are there any other things like sharutils that i should get that alot of programs depend on?
  • I wouldn't go clogging yourself up with librarys. If a program gives you an error ('X' isn't installed) or something like that, goto and search for it. For Architecture say i386 to narrow it down. You should use RH9 packages if @ all possible, if you're desparate SuSE ones will serve.

  • Wow, I have a lot to learn in the world of Linux!
  • thanks alot Q i really appreciate your help
  • One problem though, sometimes you can get errors when installing RPMs. Like when you try to install a RPM you get a error saying. Cannot find glib 0.0.0 and crap like that. Even if you already have it installed.

    Also you can get a checksum file error when you try to install one. Theres a command to bypass that though. I don't know it off hand. I try to avoid RPM files. I always use the source tarballs.
  • i have learned a few things about linux so far since you gave me that great advice, but now i find that alot of libraries cannot be found on rpmfind. if i use source taballs to install will the program depend on these same libraries? and one more thing, whenever i cd into the extracted folder from a tar.gz of a program i want, then run ./configure && make && make install, the program only works like half the time. any suggestions?
  • Just run the commands one by one. It will help out on skips and such on the build.
  • yeah that helped thanks once again!
Sign In or Register to comment.