SoundBlaster CT4170 (WavEffects) in HP Vectra QS/20 -- possible memory corruption issues

edited December 2017 in Hardware

I should be contributing here more often, but I sadly haven't really had the time. But I'm back to solve another issue.

So my awesome Vectra recently got a "new" SoundBlaster card. I had to figure out the software, but I finally got some that works. I used CTCM and CTCU and it plays sound. However, there are two problems:

  1. Windows crashes when I play MIDI files.
  2. CTCU crashes when I test the configuration.

I ran MemMaker to try to sort these things out, but I'm under the impression that something is corrupting the memory. It's on DMA 1, which is 8-bit. I'm pretty sure that this is an 16-bit card so I'm thinking that has something to do with it. I also wonder what difference the card slot makes. By the way, here is the configuration:

Driver Unit Number = 0
Base I/O Addx = 220 hex
IRQ = 5
Low DMA Channel = 1
High DMA Channel = 1

BLASTER environment is set at: A220 I5 D1 H1 P330 T6

System is most definitely not PnP. It's a Vectra QS/20 with BIOS date 10/25/90.

I'm certainly pleased with myself for getting this far, but I'm at a loss as to what to do next so that it doesn't crash. Any ideas? If you need any more (like CONFIG.SYS and AUTOEXEC.BAT), I can provide those details too.


  • Off hand I really don't know, but random crashes are usually a major pain in the butt and usually require much, much experimenting to narrow down.

    But I am a little confused. You say the first two issues are "sorted"? So somehow these stopped by running Memmaker?

    Personally, I would want to narrow down exactly what changed, because I would expect those to work with minimal drivers loaded. It probably would be a good idea to post your autoexec.bat and config.sys.

    Also, how is the rest of the system configured? What devices are on the motherboard? What other cards are installed?

    Can you describe the random crashes? Is this only in Windows 3.1? What about DOS programs?

    Have you tried changing the SB IO ports? My initial thought is that the IRQ or MIDI address might be conflicting with something.

    When diagnosing problems like this, keeping drivers and loaded software to a minimum is key. So a good place to start is to temporarily disable things you don't absolutely need just to start up and play sound.

    BTW, ISA slots are normally 100% identical. Moving between slots should make no differences unless a slot is damaged. (One exception to this rule is slot 8 on an IBM 5160 XT). PCI slots on the other hand are not identical, each slot has specific IO resources associated with it.

  • It plays sound in DOS fine (at least in the SB testing program). Windows 3.1 crashes with any sound (even the default ding sound) and exits to the DOS prompt. After that the system is in a very unstable state. In fact, if I load Windows again the mouse driver (HP-HIL) doesn't work. Same thing with CTCU. After that crashes (with a runtime error saying that "the overview manager has been overpassed" or something like that) the system will hang if I try to run another program.

    But I'll try minimizing the drivers to see what exactly works. (I had to manually parse config.sys and autoexec.bat earlier because one of the Creative programs hung the machine.) I will post the two files, probably tomorrow.

    The other expansion cards are the Video7 1024i, a LongShine LCS-1034 network card, and the disk controller/serial port/parallel port card.

    Sorry, I was probably way too brief to provide any useful information in my first post. I usually know what I'm doing, but this is my first time installing an ISA card that hasn't been previously configured. I know that it's a royal pain -- I've read a story about someone literally torching a SCSI adapter because it was so difficult.

    Thanks for the advice. I'll let you know how it goes.

  • Nice video card :) That network card is a likely source of conflict. Among other things, you might try testing without that card.

    When Windows crashes back to DOS, the state of any DOS environment left behind will always be borked. Don't worry about how that behaves. Just focus on the crash itself.

  • I don't use the network card anyway (can't get TCP/IP, only some protocols I don't use). I'll try pulling that out. By the way I was able to play a MIDI file to about 1 minute in after I changed the base address to 240H. Don't know if that had anything to do with it though.

  • OK, I took out the network card -- and now CTCM reports "Bad Serial ID Checksum (VendorID d970000) Expected=30 Actual=3." Great. Now what?

  • I put it back in and now it works again, but I'm still reinstalling the drivers.

Sign In or Register to comment.