Need help - can't get my 1989 MiTac MPS-3000F to work

Hi guys,

Recently I bought an vintage Mitac MPS-3000F second hand off the internet. Normally, I like to mess around with old stuff in VMWare. This time I wanted to re-install a physical pc. And it causes a lot of headaches already, after a major search for information for over a month. This post is like a last resort-effort to get some help. Because, I can't get it to work properly.
Here's the information about the machine, and a summary of things I did.

The Mitac is from 1989 and does have a 25 MHz 386 Intel processor on a motherboard made by Mitac themselves (according to an article from PC Mag in 1990 found on Google Books) The type/serial number is unknown to me. It has a Phoenix 80386 Advanced ROM BIOS, version 1.02.00 (R2.12.00C).
The motherboard is an MCA board with a single SCSI connection, with hosts an 3,5 and a 5,25 inch floppy drive. Both of them are working. The CMOS battery is dead. It used to have a harddrive, but it was removed and destoyed by the previous owner. So, it is currently running without any OS. I have tried to enter BIOS, but without success. I have tried every key on the keyboard and every known combination of keys, no success. But this might not be my biggest worry.

On the board are a couple of cards connected to it, most importantly an Adaptec AHA-1640 SCSI controller card. This causes the first major problems, since I can't get it to work. I bought a (working) SCSI harddrive (a IBM WDS-3200 with 200 MB) off the internet, which I like to use. I also have a SCSI cd-rom drive. Both of these are not working of course.
I have tried to check the SCSI ID's. The harddrive that i've bought has ID 6, and I can't find the ID number of the cd-rom.
If there's a problem and it's fixable, I will run into an even bigger problem: the controller card itself doesn't show up. I think because the CMOS battery is dead and the initialization parameters are missing because of that (since I've read that those parameters need to be on the CMOS memory).

I have searched the internet and found a couple of things that might be working, for example an adf-file (with contains the initialization parameters), and an installation manual. Problem is: the manual says that I need a System Reference Disk (SRD), which boots my pc, and then I will be able to load the adf-file into the CMOS memory. I do have the option to use a couple of AA-batteries to power the CMOS, so that is no issue.
What is an issue, is that I do not have a System Reference Disk for my Mitac. I have read that IBM has manufactured MCA bus boards, and that Mitac has used MCA too under licence. Problem is: finding information regarding any SRD for my Mitac (if there is any) is next to impossible.

So, here is where I need your help:
Is it possible to use an IBM SRD, if so, which one? Or is there a "generic" SRD somewhere? Information is really scarce, so anything useless to you might be helpful to me. Because it feels to me, that this is the key to solve this all. If not, i'd like to hear it of course.

Feel free to ask any question, if you want to know more.
I appreciate your help in advance!

Cheers, Rik.


  • A lot of older computers like that don't have a real BIOS, instead just a little program that helps the computer boot. I suggest searching for a third-party bios if the ROM ( EEPROM) chip is removable.

Sign In or Register to comment.