Windows 3.1 "Out of Range"

So, long story short, I have an IBM PS/2 model 80, with an IBM XGA Adapter/A (Not XGA-2, XGA-1)

I install MS-DOS 6.22, and Win 3.11 For Workgroups. I install the XGA adapter driver, it installs fine. When I go to reboot into Windows, it puts my monitor out of range. I control+alt+del and I get the typical bluescreen from Windows 3.11 when a program is not responding - it says there are no such programs not responding and press enter to return to windows, etc. So it clearly is in Windows it is just does not have the correct display modes? I read the readme on the XGA driver disk I found ( XGA/XGA2 Option Diskette v.2.2 and it said that display modes can be chosen in Windows with a control panel applet...

But I can't even get into Windows...

I've got this monitor, which supports up to 1280x1024.

It supports XGA resolutions as well, 1024x768, here's the full chart (from the manual)

Anyone have any clue on how to fix this?

I have tried installing Windows 3.1 with the same driver, rather than installing it and then adding the XGA driver later, and when it reboots into the second part of Windows installing, I get the same problem of the out of range monitor. I've tried another monitor with the same issue.


  • The original XGA only supported 1024*768 43.5Hz interlaced resolution. That is not on your monitor's compatibility list. You will either need a later XGA or a less lobotomized monitor.

    I can’t seem to find a complete list of what other resolutions and timings original XGA supported off hand

  • then again, it's probably not good for your eyes to not look at ~43.5 Hz CRTs; consider it a safety feature!

  • This seems to be related with your XGA.
    I recommend to replace XGA-1 with XGA-2 if possible.

  • Luckily I had a CRT laying around.

    Now, however, when I try to run the XGA applet, Main->Control Panel->XGA Setup

    I get this error

    "Your display type is not defined in the XGA Display Information Files, therefore no setup information is available. Select another display type."

    Got any idea on how to fix this?

Sign In or Register to comment.