“Fresh” Apple Mac OS 9.1 ISO

edited September 2018 in Offers & Requests

Hi. I found a packet of Apple-related CDs at a thrift store; one of them was an install disk for Mac OS 9.1. I know there’s already a 9.1 ISO on the site; however, it’s marked as (Bad?), and I think that might be true. I made an ISO of the disk I found, and uncompressed, it has a size around 680 MB, almost 100 MB more than the ISO from here after decompression. I tried the ISO from here and my own ISO, and the one from here seems (admittedly with barely any testing) fine except for this error and the CD-ROM being listed in a strange manner in the Drive Setup utility, which I forgot to screenshot and now cannot reproduce, because of course; however, there is a possibility that it is corrupted in some way considering the size difference, (Bad?) label, and behavior that I did not experience with my ISO, or perhaps it's just a different CD version (my CD is labeled “Mac OS version 9.1”, and “CD version 1.3”). Or I just don't know how to use computers (honestly this is probably what's happening). Even 7zipped, my ISO is 400 MB, so I’m hesitant to attach it if it would be inconvenient to delete in the event that it was insignificant; I poked around some Software threads to try and get a feel for the precedent but I’m not quite sure what the etiquette and convention is for files on the forums, and how that meshes with the Adventure CMS; could someone more experienced help me out? Also, sorry for the wall of text, but I can’t really think of any good places to break it up :neutral:
Edit: added a word for comprehensibility


  • Welcome and thanks for the offer. This would probably be better in the Offers & Requests section. Currently, offers need to be uploaded to a cloud storage provider like Dropbox, Google Drive or MegaUpload, then linked in the forum. We also will generally notify @SomeGuy (<-- just like that), who is doing most of the library management.

  • As for the error, the problem is not any of much matter. Thhe problem appears because you tried/the installer tried to update the hard disk driver, when it was unnecesary. So I think your ISO might be ok.

    Also like Totengeinst said, please post a link to the ISO, so the community can help you with your offer and with any problem that may exist with your contribution

    IMO your ISO looks good in general. Could you tell us whether you tried this in an emulator or in actual hardware? (If you did in an emulator: In what OS did you used the emulator and what emulator did you use? So we can try to reproduce the problem)

  • Thanks for explaining. I’ll upload it somewhere (prob. Mega), and post in Offers & Reqs. To clarify, the ISO ripped from my CD-ROM wasn’t the one with quirky behavior, that was the one listed in the library and noted (Bad?); however, I actually haven’t been able to get either error to reappear. With regards to setup, I’m using an emulator. I have a desktop and laptop computer, both w/ Arch Linux, and QEMU as an emulator. I’ve used my CD directly with QEMU on the laptop by using the disk drive device file (/dev/sr0) as a -cdrom argument directly, with the Software Install disk in the drive; however, that didn’t work with the desktop computer, so I made an ISO of the CD for use there.

  • Did you include a scan of the CD label? Is this a retail version or machine bundled version? The big problem with MacOS is that Apple released many machine-specific variants.

    Also, what did you use to dump the CD? I think the problem with the currently posted image is that someone dumped it with Apple Diskcopy which only dumps the Mac volume within the ISO, and not the CD ISO info itself. That make the resulting image only useful in an emulator, not for burning back to a CD.

  • Here’s my Offers & Reqs. thread, it lists the CDs, and here’s the Mega folder, I’ve added a “pics” folder with hi‐res images of the CDs and the packaging. The install/restore disks are iMac‐specific.

    To dump the CD, I did “dd if=/dev/sr0 of=file.iso”, which isn’t working now for some reason.

  • Uh, that might work much of the time, but that is generally not a good idea. Some oddball CDs won't work like that.

    We normally recommend dumping ISO images with ImgBurn, however REALLY oddball or copy protected disks may need to be dumped as MDF with Alcohol 120%

    I seem to be having some problem writing the image to a test CD. Not sure what the issue is. Seems to be some size mismatch?

Sign In or Register to comment.