Windows 95C on a ThinkPad T41 - issues

edited November 5 in Hardware

This 14 year-old Pentium M 1.6 GHz/512 MB RAM/40 GB HDD has taken very well to Windows 95, with working audio/MIDI synth, USB bus, and likely Ethernet drivers. I find that performance is superior to 98SE/2000/XP on the hardware.

Unfortunately I've run into a few snags:

1) has anyone ever been able to find a working ATI Mobility Radeon 7500 driver for Windows 95? The ones I've found boot to blank screen or a blue screen citing an invalid dynamic VxD link. I'm using the SDD 7 beta driver, which does work quite well though, except for the obvious 3D hardware acceleration limitations.

2) I can't properly shut down. I am left hanging at the win95 shutdown screen. Even shutting down to DOS never works, leaving me at the blinking underscore. Luckily, forcing a shutdown never results in a forced scandisk upon boot. This issue arose after installing the extended USB supplement.

I would appreciate any assistance with these problems.

Comments

  • @win32 said:
    Luckily, forcing a shutdown never results in a forced scandisk upon boot.

    Why is this having luck? Everytime you kill your computer it does not get checked. It wouldn't dare to do this.
    It is due to lack of ACPI and/or APM support in Win95. These two words should help finding a solution.

    If you cant find drivers, you may use a general-purpose video driver like SciTec Display Doctor.

    I suggest switching to Windows 2000 on this machine. This is the oldest Windows-OS that can take advantage of your hardware. With Win95 a lot of "power" is lost.
    Starting with working USB-Mass-Storage, USB2 and graphics.

  • Windows 95 has hardware limitations in general. I'd suggest either Windows 98SE or 2000 on that laptop. I actually ran Windows 98SE on my ThinkPad R40, which worked very well, but, the Wireless ABG card drivers were limited to WEP or open security and ended up installing XP on the laptop itself, and it's low on storage, plus, the HDD is starting to go (going to purchase a couple of mSATA to 2.5" IDE adapters and a couple of 32GB or so mSATA SSDs for my ThinkPad R40 and the 2 Dell Inspiron 600m laptops I have), then clone the drives without having to reinstall the OS itself.

  • @Windows7User2010 said:
    limited to WEP or open security

    My fancy new cable-and IP-TV-enabled-super-usb-whatheckelse-router does not support WEP, old WPA or open anymore. Like mine there are already several new routers omitting these old crypt-methods.
    For my old Dell AXIM PDA I have to set up a second wireless card in my laptop and use hostapd+iptables to make a new (unsecured) network and route between.

  • edited November 5

    I tried running 95 on a T40 once with no luck. You've actually gotten farther than I did. I ended up putting Windows ME on it which, surprisingly, actually runs okay (better than 98SE, actually) I hardly ever use it though except when I need my Digigram VXpocket V2 sound card.

  • edited November 5

    However, I think the OP doesn't wants recommendations about what OS to switch for this laptop. IMO he installed Win95 for fun and to experiment, so if you can help him with his problem rather than blaming the OS and saying to switch, that could actually be useful.

    Also, the affirmation of Win95 not having ACPI is incorrect. Windows 95 is able to shutdown by itself in a VM and in physical hardware. But the problem is actually related to the ACPI functions. Check in the list of drivers for anything related to ACPI or APM, like "Power Management" or "ACPI function" or so. Once you found them, uninstall them, hard reset the machine (Power off completely and then power on) and see if you can shutdown now. If you can, some ACPI/APM drivers were the problem, but if you still can't, then the problem is another driver. Try uninstalling anything that the USB drivers installed, even the USB drivers themselves, and then see if you can shutdown.

    Take in mind that the first time after deleting the drivers and hard resetting you might be able to shutdown, but not the second time. This because the drivers Win95 detects and installs might be the actual problem

  • @SistemaRayoXP said:
    However, I think the OP doesn't wants recommendations about what OS to switch for this laptop. IMO he installed Win95 for fun and to experiment, so if you can help him with his problem rather than blaming the OS and saying to switch, that could actually be useful.

    I did, before I suggested Win2000.

  • edited November 6

    Thanks for all of your suggestions.

    As much as I want to put Windows 2000 on everything with a CPU in it, I already run it on another desktop of mine, and this laptop is my only piece of 9x-compatible hardware that still functions. The hardware MIDI synthesizer also only has 9x (VxD) and NT4 driver support.

    I'm going back to Windows Me, but I'll try using some of the Intel USB 2.0 drivers instead of manually installing NUSB ones to avoid what was my only stability issue with the OS. I thought about NT4, but it's very limiting in terms of compatibility compared to Windows 9x.

  • edited November 6

    @sdose said:

    I did, before I suggested Win2000.

    @SistemaRayoXP said:
    if you can help him with his problem rather than blaming the OS and saying to switch, that could actually be useful.

    Well @win32, I think you should at least try, but another 9x OS should also work. And I'd recommend you to use Windows 98 instead of WinMe, since Win98 has more stable drivers than Windows Me, and also has the DOS mode, which is very buggy in WinMe

  • I did install Windows Me, which gave me a grand total of zero BSoDs in about two hours after installing all drivers, but I dumped it for 98SE because the latter is something that I actually used when I was younger (along with 95, 2000 and XP) and Me looks like a cheap win2k knockoff.

    So far so good with win98se, but I just have one issue that affects both OSes: poor shell responsiveness at the start of USB 2.0 transfers. The unofficial shell32 update has improved things, but the only complete fix appears to be in the unofficial service pack (which introduces its own problems, causing me to abandon win98 in the past). I've downloaded Norton Commander 2.01 to see if I can avoid this issue by not using windows explorer.

  • Don't forget to install the DST patch as well from the Unofficial SP3 for 98SE.

  • NC is DOS and I assume file operations in that DOS-environment of Windows are not "better" than Windows Explorer.
    You may try "Total Commander", this exists for ages and is quite good. It is shareware. The most recent version still runs fine on Win95 on a 486 here.
    It is very much like NC.

  • edited November 6

    The slowdowns also occurred with the alternative shells, so I decided to replace the usb drivers with the ones from the USP package (win2k/XP files), and now my file transfers are much faster than before with no freezing!!

    Once again, thanks for the recommendations.

  • I forgot to mention this earlier, and I mention it every time someone does a Win 9x install: Open up the device manager and find the first IDE hard drive. View the properties of it, and enable DMA on the drive. Also do this for the CD-ROM drive. Windows 9x doesn't do this by default, but it will speed things up since it won't be using CPU cycles whenever the drives are accessed. A lot of people have forgotten about this over the years.

  • @nick99nack The enabling of DMA for HDDs is also an option in the 98SE USP. Thanks for the reminder anyway.

    After installing Corel Draw 8 (with just under 500 extra fonts!), the shell became so slow to the point that windows draw themselves open and closed. Removing IE should help, but it just shows how horrific the win9x implementation of the IE-integrated shell was. I haven't had the same issue with the 95/2000/XP shells on the same hardware.

  • Gotcha. I forgot about the USP. That's odd though, I've used that program on 98 before and didn't have that problem. Maybe something in the USP caused it? (I've never used it)

  • I actually didn't install the USP's main updates, just the DMA enabling, frontpage express, time zone updates, directx, 250 truetype fonts, and manually replaced some winme native USB drivers with win2k ones.

    As I said, it may be about the 500 fonts I installed with Corel Draw; Windows 95/98 support a max of 1000 fonts, and I guess with the system fonts, Office 2000, a few other cheap CD-ROM programs, I was scraping up against the limits already.

Sign In or Register to comment.