I #*(&!%@ hate OS/2 Warp 4!

edited April 2019 in Software

I've been trying to install it on real hardware (Pentium 200mhz) for a demonstration, and it reminds me how stupid IBM was.

Right off the bat, put the wrong "boot" floppy in the drive an instead of getting a meaningful english "non system disk" type error I just get some crap like "!!SYS49221" that tells me nothing.

Then it makes you load three "boot" floppy disks, which takes a long time as expected, only to make you START ALL OVER if the drive is not already first partitioned!

Of course, it can't deal with an 80GB hard drive on a machine which lacks LBA support. Setup craps itself unless I manually partition it, but not too surprised there and at least that part works.

Then, it appears that if I install networking components on this machine it will crash and burn at startup, with no obvious way to recover other than wiping the drive and starting all over again.

It took quite a bit of retrying to finally get to the OS/2 desktop.

And then, if I run the fixpack directly from a real CD it seems to crap itself and leaves the system in a half updated state, that if course won't boot and forces me to start all over from scratch AGAIN!

Oh, yea, it has a "dual boot" feature that lets you start up in DOS if it was already installed. But it is not a boot manager like most would think of. It is just a pair of programs that renames the boot system files and reboots. Of course, that requires you to fully start OS/2 (or DOS) to run the program. Unless you have read the manual, you would have no idea what program to run under DOS to return to OS/2. If you just happen to guess that it is BOOT.COM in the OS/2 folder, it completely and unhelpfully informs you that you specified incorrect parameter. Turns out the appropriate magic incantation is "BOOT /OS2". I'm supposed to know this how exactly?

It wouldn't be true-blue IBM if it did not make you pull a thick three-ring binder off of a shelf filled with dozens more, and flip through it by numeric code for the answer. :P

I also tried installing in in VirtualBox. A bit less of a hassle, but the boot loader would just sit there for 20 minutes or so before the boot disk or OS/2 would actually start. Problem seemed to go away after the final fixpack was installed. Probably a VirtualBox problem.

Oh, and the sound driver is supposed to be installed after the fixpack.

Of course no one made video card drivers for it, so it's off to the half assed Scitech Display Doctor, which seems to cause OS/2 to hang at shutdown.

Oh, well, I thought I got it all installed and working, only it hoses the hard drive for no obvious reason, it boots but claims the desktop folder is missing. SO I HAVE TO START ALL OVER! Well, this time I thought I was smart and zipped the contents of the hard drive. Unzip over the files... and it still thinks the desktop is missing AND it crashes in a loop.

Ok, so started over AGAIN... this time I wized up a bit more and created a second partition and now I will use Norton Utilites to backup the the primary partion to an image file in the second partion after every tiny step. (at least so far nothing has hosed the partitions and its just keeping it FAT16).

Good thing I did, because after running the fixpack, it wouldn't boot again!

At this point I'm thinking Solaris 8 would be less of a disaster (but not by much).

Edit: Try to work on some VMs on my Windows 10 test box while OS/2 is flopping around, and of course Windows 10 shuts down while I am working on it and decides it MUST do some massive "update" right this moment. I just can't get a break can I? I wonder what features Microsoft has removed now?


  • edited April 2019

    Today I just hooked up my IBM PC 300GL and found the three floppies I used in my Warp 4.5 install attempt about eight years ago. For some ridiculously stupid reason (that I forgot), it basically told me "after swapping them floppies, and burning your last CD-R to install this rare OS, I'm not gonna let you!!!! bwahahahahahaha" It was probably some weird code for an issue that fixpack 666 could have solved.

    I also tried installing it on a ThinkPad T41 (from 2004) and it tried to get me to make floppies in order to install the drivers. I've never needed floppies to install Windows 95+ drivers!

    They also wanted users to pay for USB drivers, around the time Windows 2000 shipped with a universal mass-storage class driver.


  • I once installed OS/2 Warp 4 in VirtualBox, and it somewhat worked, but networking didn’t work at all and the video drivers were basic VGA drivers. It felt quite disappointing to say the least.

    Speaking of Solaris 8, when I tried installing it in VirtualBox the first part of setup worked fine but then crashed.

  • VirtualBox guest additions are available for OS/2, but they ask you to install them manually with some long-winded instructions.

    From the sounds of it, Solaris 8 probably fits in between waterboarding and constant 120 V shocks to the extremities.

  • edited April 2019

    I finally did get the fixpak installed, it appears as if some "locked" files were not getting updated. I cloned the drive, booted off of the other drive, and then ran the fixpak on the original's installation. Of course, it is SUPPOSED to be able to handle locked files. No idea why it wanted to fail now, since I had gotten it to install once before (but had to nuke that install) and on the VMs.

    Interestingly, after all of this time, nobody has publicly posted IBM's "top secret, subscribers only" Fixpak 16 xr_m016 or Fixpak 17 xr_m017.

    Then weirdly, the Scitech Display Driver's settings window kept freezing the system every time I clicked on it, but after some fiddling (resizing the windows?!) it started working.

  • One time I tried to install OS/2 Warp 4 in VirtualBox, and by the time I thought the installation was going to be successful, it just froze. You're right, OS/2 is quite complicated to install on anything. I guess IBM can learn a thing or two from it's past :|

  • edited April 2019

    They did. SPSS version 24 is very intuitive (though most of the other SPSS users around me hate it).

    I just found this picture displaying what OS/2 did when I was trying to print screen

    I wonder if ArcaOS is any better than Warp 4.x in terms of usability?

  • I just found this picture displaying what OS/2 did when I was trying to print screen

    Well, if you want to print screen then, naturally, you need a printer. MS DOS worked the same way thus I'm not sure why would you think OS/2 should suddently do something different.

    There are programs which allow you to save screen in file (e.g. here: http://home.hccnet.nl/w.m.brul/snapshot/index.html ), but remember that OS/2 was designed as replacement for DOS, not Windows 10!

    P.S. This being said it probably would be a good idea to have prepared images of different OS'es (maybe with some softwrae, too) ready to run in emulators. Because things which were "normal" back then are no longer "normal"... we are not just losing sofwtare (and thus sites like winwordpc are invaluable), we are losing an expertise, related to software, too - and may eventually end up with the bunch of archives... which one knows how to use...

  • Ahh the joy of old operating systems. It's quite easy to forget just how far we've actually come.

    Windows 10 has its flaws, sure. But installing it is a breeze. Next-Next-Finish and for the most part I didn't even need to hunt down any drivers. Things just work.

  • I've had reasonable luck in 86box, if you want to go the virtualization route.

  • And the icing on the cake, the USB port wasn't working (using a different OS for that) so I fiddle with the USB backplate's plug to the motherboard and something on the motherboard lets out some magic smoke. Looks like I killed the USB ports but I wasn't using them anyway and at least the rest of the motherboard is still working. Ah, it looks like it was disabled in the BIOS after I replaced the CMOS battery. I just can't win, can I?

  • Sounds like you got some bad BAD luck...me? I've been dealing with trying to find a goddamn serial number for atleast 1 out of 2 things in a Compaq thingy. It requires a serial number and what it wants it from I do not have that lmao.

  • At the last minute I decided to install Solaris 8 on a spare alternate drive. It was just select the defaults, specify the video card, and it all just worked. But then again I already knew this hardware was compatible with Solaris 8.

    Oddly, emulators and Virtualbox don't seem to like Solaris 8 at all.

  • I actually got Solaris 9 installed in VirtualBox, but there was basically no drivers. I deleted that VM a while later.

  • @win32
    In reply to (I also tried installing it on a ThinkPad T41 (from 2004) and it tried to get me to make floppies in order to install the drivers. I've never needed floppies to install Windows 95+ drivers!)

    Same problem with me, brought the drivers all from CD on my t41 all recognized. It wants to install them on floppy, but as you know t41 doesn't have internal floppy drive. My IBM USB floppy drive, doesn't get recognized either, can't say iam surprised. Tell me if you had any success getting those .exe drivers working as just files not a floppy.

  • "Interestingly, after all of this time, nobody has publicly posted IBM's "top secret, subscribers only" Fixpak 16 xr_m016 or Fixpak 17 xr_m017."

    At last.

  • On the subject of the T41 (it seems I prepared a reply nearly two years ago but never sent it):

    It seems that getting the drivers from here: https://hobbes.nmsu.edu/?path=%2Fpub%2Fos2%2Fsystem%2Fdrivers will allow you to bypass any floppy requirements. For my T41, I found the SoundMAX Analog Devices v3.1.9 driver, along with a SNAP driver for my Mobility Radeon 7500. The first one installed through Multimedia Application Install, the second by typing in "setup snap" in the folder in the OS/2 command prompt.

    Side note: the installer executables (that do nothing but extract the files to floppies) for many of the OS/2 drivers from Lenovo are in fact 16-bit OS/2 console applications, which ran on Windows NT/2000. Also, Windows 2000 setup will detect an existing OS/2 installation and add it to boot.ini.

    And I did get it running on my older IBM desktop as well. eComStation 2.1's setup is considerably simplified over the IBM setup.

Sign In or Register to comment.