Internet Explorer 5 for Unix - Solaris 2.6

I got the solaris 2.6 image from winworldpc.com working!

I used El Captian + Homebrew + Qemu. I had to first build Qemu with homebrew and that was the longest build ever, a few hours. Homebrew had a few warnings saying it no longer supports El Capitain, but it worked regardless. I can't take any credit. Someone wrote an amazing tutorial here:

https://learn.adafruit.com/build-your-own-sparc-with-qemu-and-solaris/overview

I couldn't use the IE5 solaris bzip2 file from winworldpc.com because bzip2 says the file is corrupt.

So I found this instead.
https://browsers.evolt.org/archive/ie/solaris/5.0/ie5setup.sunos5.gz

Keep in mind that solaris 2.6 does not have bzip2 or gunzip .. just tar. So I gunzipped the file on my mac before using classic ftp to transfer the ie5se3tup.sunos5 over.

After running the setup from the command line, it ended with a successful message:

Internet Explorer 5 for UNIX Installation is Complete!
You can run iexplorer from /export/home/ietester/ie5/bin

Unfortunately when I run iexplorer, I got the following error when I try to run IE from the command line:

Error: OS patch(es) required to be installed before running Internet Explorer. See error log at /var/tmp/IE_host_check.err
For more information see: /export/home/ietester/ie5/sms/mwcheck_platform.README

The install log is complaining about a Shared library fix for C++ compiler runtime.

I need the patch for the C++ Compiler seems to be the solution.

Does solaris 2.6 need some type of update from a fresh install?

Comments

  • Most likely. If you just need to use Solaris IE, then I would suggest Solaris 7.

  • edited June 11

    Before I start a new install with Solaris 7, I thought I'd document some thoughts just in case someone else wants to go this route.

    1) The first Failure states that the Kernel doesn't meet the minimum requirement, so the following patch 105181-23 or greater (105181-24 etc) is needed. sunsolve.sun.com may be closed, but the patch lives on at archive.org:

    https://web.archive.org/web/20020304234318/http://sunsolve.sun.com/pub-cgi/retrieve.pl?type=0&doc=fpatches/105181

    2) I suspect the 2nd failure is possible because I have no build tools installed. I didn't check the developer option during the fresh OS install.

    Conclusion:
    I also suspect I need to install the developer option before I can even run any patches, because patches are compiled.

  • edited June 13

    Hi Robobox!

    I tried Solaris 7, and that one needs 3 patches. So I downloaded Solaris 8 which seems to be for both x86 and Sparc, not sure which of the 3 cdrom iso files to use for Sparc?

Sign In or Register to comment.