Windows 3.0 reboots during installation

I managed to score original Win3.0 disks on eBay for $11. I'm trying to install it on my Toshiba T3100 (8 MHz 286, 640k, 10 MB HDD, 720k 3.5" FDD). I have about 7 MB free disk space. The text-based portion of setup goes OK, but when it's supposed to go into the graphical portion, the machine reboots. This happened twice. At that point, WIN.COM is in the Windows directory on the disk, but it won't boot, so that's not a way to continue setup.

I tried to look up this issue, but can't find anything similar. What am I doing wrong? Incorrect device drivers selected? Bad disks? Machine not up to the task?

Comments

  • That is a little odd, Windows 3.0 was fairly stable, at least as far as getting it set up and running.

    I'd suggest running some diagnostics such as CheckIt or Norton Diagnostics (part of the Norton Utilities). Use something like the old McAffe Scan for DOS to Make sure the machine and the disks don't have any old viruses on them.

    You can compare the disks to those on Winworld if you suspect the disks are damaged.

    Does this really only have 640K of RAM? No XMS? That could be confusing it. On a 286, Windows 3.0 needs at least 1MB . You should be able to start Windows in real mode by running "win.com /r", but it won't be very useful.

    If the motherboard does have more than 640k installed, check the version of HIMEM.SYS that is installed, try different versions, and if is set to use any HMA/UMB or any other memory management, try disabling those temporarily.

  • I figured it out! I ended up running the virus scan (all good), then trying to install it on my Vectra QS/20. That crashed too. So I installed it in VPC 2007 using my disk images, and it worked. So I knew something was wrong with the configuration.

    As it turns out, it was the graphics driver. Setup automatically selected the Olivetti/AT&T monochrome adapter, which the Toshiba T3100 was only partially compatible with. I manually selected CGA and it installed fine. Looks horrid, but works fine.

    It automatically starts in real mode due to the low RAM. The RAM expansion card is a very tough find, and I'll probably have to buy a whole other T3100/3200 to get it.

  • edited July 10

    Welcome to the t3100 party. I'm glad someone posted on here about one.
    Which t3100? Your 10mb hard drive says original release.
    Non sx versions should have high res cga support, though 2 bit only dithering on the plasma. If you had the t3100e, it can officially do ega. Both e and non-e have the same resolution pdp, so I'd give ega a try. And depending on where you read, the non e versions have it or not.

    If you're into a bit of soldering, it is possible to desolder and solder in new ram chips. Probably bump you to a little over 1 meg, enough for standard mode.

    I have the t3100sx, which I'm working on. No, my ram modules are not compatible.

    Be wary, t3100e models use different memory modules as well. So does the t3200sx/c models. But I have a feeling you'd enjoy one of those as well. I've enjoyed my German t3100sx since I was a child (family computer).

    And yes Someguy, the stock t3100 came with only max conventional memory, and about 128k is taken by the rom. Only with the introduction of t3100e did they finally bump their stock offering 1mb. The 286 t3100's and t3200's do have ems+xms, but as op said the ram modules are rare. On the t3100e, however, you can mod certain simms to addon. On the t3100sx, we're back to proprietary. I think, correct me if I'm wrong, but the t3200sx/c could have the possibility of modded simms as well.

Sign In or Register to comment.