16-bit Applications Freeze (WinXP)

edited July 2019 in Software

I have a computer at work with Windows XP, and there is a 16-bit program I'd like to run on it. This and other programs have run fine on other XP machines, but on this particular machine, if you launch any 16-bit application, the program just freezes immediately and the only way to stop it is to kill NTVDM. I'm guessing something got corrupted somehow. Any ideas?


  • edited July 2019

    Have you tried replacing the NTVDM.exe and NTVDMD.dll with those from another XP machine? You'll probably need to disable WFP to make that happen.

    Does it have the same level of updates as the other XP machines?

  • I tried copying those over from a working machine, but it didn't help. Patch level I believe is the same. I can't remember for sure, but I think I applied all of the updates, up through and including the ones just recently released.

  • edited July 2019

    Have you tried in safe mode? I looked up a similar incident and NTVDM worked in that case. So a driver or startup program may be interfering with it.

    My win2k boxes had an issue with "PowerTweaks" (mmm.exe) where clicking on the toolbar in any WOW32 program would crash it. Removing it from startup/execution fixed that problem.

  • What happens if you try to run a DOS program?

    Does this even happen for simple 16-bit excutables? Try something like the Windows 3.1 CALC.EXE.

    Sort of a shot in the dark, but perhaps try disabling video acceleration. I have seen a really bad video driver cause problems like that once.

  • I used a DOS-based address book up until recently and that ran fine. I'll have to try again on Monday.

  • edited September 2019

    Did you resolve this issue? It sounds exactly like a problem I had with some older 16 bit programs running on 32-bit W7.

    Launching any application that ran in NTVDM would fail, NTVDM would use 100% of a single core, and the application would never launch. Both Win16 and DOS programs were affected. Even in Safe Mode it would not work.

    It was determined to be an Intel Core i5 microcode issue. Had to update the Dell BIOS which included microcode updates. This was narrowed down by imaging the drive and booting the image on a nearly identical Core i3 system. As soon as the image was booted on the i3 the application would run.

  • I never did get this working. DOS programs still run fine on it, but I never got around to tinkering with it. I ended up running it on another machine. If I get some time I'll try it again.

Sign In or Register to comment.