Installing Microsoft Windows NT 3.1 (10-16-1991) October 1991 build

Hi - I've installed this build in VMWare but it doesn't seem to include the Windows GUI, or at least I can't start it. I followed these steps:

  1. Boot from windows 95 boot disk to run FDISK and create primary dos partition. Run FORMAT and format drive C:
  2. Boot from windows 98 boot disk (to enable CD-ROM support) and insert ISO in drive D
  3. Run d:\setup\install.bat - WinNT says it installed successfully (there doesn't seem to be a GUI install option)
  4. Reboot and it shows the 'starting windows 95' splash then dumps me back to MS DOS. There seems to be no way to to start the Windows NT GUI (see steps below)



As you can see, it seems to have installed NT, but I can't get into any windows GUI. Has anyone else had any luck with this build? Cheers.

Comments

  • You will probably need to use MS-DOS 5.0 (the current version at the time of release) instead of Win9x's DOS 7.x.

  • Good point - will try thanks!

  • I'm pretty sure anything below Windows 95 should work. And 99% sure Windows 95 would work, too - but only if you would use some other FDISK program.

    By default FDISK from Windows 95 creates LBA-type partitions 0E/0F (see table)

    Also, when program says "disk error writing drive C" it usually means installation is NOT succeful...

  • edited February 15

    Thanks for the responses - you were both right. I formatted using MS-DOS 5 and it installed - eventually. I had to lock C: drive as well as it would disable direct disk access on install (https://jeffpar.github.io/kbarchive/kb/140/Q140372/).

    Anyway it installed and got to this -

    I added a COM port and then got this, which is where I'm stuck for now:

    Is there supposed to be a Windows NT GUI following this? It's not halted, as the CPU usage shows. But it won't accept any text input either. It just sits there indefinitely. Was this a mode used to output debug information to another PC via a COM port? Is there a GUI? Hopefully someone with more knowledge than me can answer. Cheers.

  • Installs easily in 86Box, also keyboard works.

  • Thanks jonirob, I will try with 86Box.

  • edited February 16

    jonirob - can you post what settings you used with 86box? Specifically what machine ROM you used? I can't seem to get any of the included BIOS roms to recognise a 3.44" boot disk for anything, or even detect a floppy drive for that matter. It can detect the added HDD no problem.

    Secondly, did you install straight from the NT CD ISO image or DOS 5 first?

    Thanks.

  • edited February 16

    @user1235 said:
    jonirob - can you post what settings you used with 86box? Specifically what machine ROM you used? I can't seem to get any of the included BIOS roms to recognise a 3.44" boot disk for anything, or even detect a floppy drive for that matter. It can detect the added HDD no problem.

    Secondly, did you install straight from the NT CD ISO image or DOS 5 first?

    Thanks.

    Machine: [Socket 7 VX] Epox P55-VA

    CPU: Intel Pentium 75

    Memory: 32MB

    Video: [ISA] VGA

    Mouse: Standard PS/2 Mouse

    Hard Disk: IDE 0:0 500MB

    Floppy: 3.5" 1.44M

    CD: ATAPI (0:1)

    I used 86box_roms_20190213 and Windows 95 boot disk.

    P.S. I used the text based installer.

  • edited February 17

    Thank you! I had tried a number of different machines but they all halted after POSTing with no explanation. Switched to your machine config and it booted instantly.

    Turns out the floppy issue was really stupid on my part - I had it in slot 4 instead of slot 1.

    Thanks again.

  • @user1235 You're welcome. The magic of 86Box!

Sign In or Register to comment.