Windows 2.11 (286) on a IBM 5170 8mhz freezes on startup

Hi all,
I've been messing around trying o get Windows 2.11 (286) installed on my IBM 5170. I can get it installed fine but when I type win I see the the windows logo a little garbled and it freezes. Im using MSDOS 6.22 and a OAD 1MB VGA card. I've selected VGA in the install and did not select the extended ram as MSDOS always has himem.sys loaded.

Any ideas?


  • Make sure SETVER is loaded, and that there is an entry for "WIN200.BIN" to report DOS version "3.40" (that entry is normally in setver by default). Otherwise Windows 2.x will crash at startup under DOS 6.x.

  • edited April 2020

    I installed Windows 2.11 (286) on IBM PC-DOS 5.00 with IBM PC 5170 (Type 1, 512KB).
    Yes, Windows 2.11 doesn't work on DOS 5.x or higher.
    So you should load SETVER.EXE on CONFIG.SYS as follows.


    Then, you should run SETVER.EXE as follows.


  • edited April 2020

    Thanks for the replies. I've added to setver win200.bin to 3.40 and 4.00. When I type setver I see the new entries. I still get a frozen stash screen with the logo a little garbled. I've tried using EGA just in case its a conflict with my VGA card.

  • Hmm, it does look like something else is going on here. I'd sort of expect all this to work fine on a genuine IBM AT, but it did have some peculiarities.

    Just a few random ideas:
    Try Windows 2.03 instead, at least just to see if it works.
    Try not loading DOS in high memory. (DOS=LOW in config.sys)
    Try using the himem.sys provided with Windows 2.11 (not really recommended under DOS 6, though)
    Try disabling any disk caching, or other resident programs that might be using XMS.

  • Right got it working. Well sort of....

    It looks like the problem was with my OAK VGA card. It was probably not 100% VGA compatible or needed some sort of windows 2.x driver. Probably impossible to find if it even existed in the first place. Hence the strange distorted Windows logo splash screen.

    I've taken this time to re-setup my IBMS. So My IBM 5170 now has IBM PC DOS 5.02 installed and I've put my VEGA Video-7 EGA card in there using my IBM 5153 colour monitor. Just trying to be more authentic.

    I've reinstalled windows 2.11 and selected EGA. It looks like its using the full EGA 16 colour resolution of 640x350 because my 5153 monitor can't handle the resolution.

    Is it possible to force Windows 2.11 to use EGA 16 colour 640x200 instead? So I can use my 5153 monitor. As I don't have an Enhanced IBM monitor :(


  • Right, re-ran the install and selected low resolution EGA. Now working perfectly. :) Thanks.

Sign In or Register to comment.