Windows XP update method provided by users here no longer works

A while ago I made a post here asking how to update Windows XP machines. After lots of talk, I had a surefire way of doing it that worked 100% of the time and never had any issues. I just had to follow these steps:

1. Install the 07-2019 root certificates
2. Install Internet Explorer 8
3. Install version 3.0 of the Windows Update Agent
4. Go to Internet Options and make sure that TLS 1.0 and SSL 3.0 are enabled
5. Head to the Security tab and make sure "Automatic prompting for ActiveX controls", "Run ActiveX controls and plugins", and "Script ActiveX controls marked safe for scripting" are set to Enabled

Upon opening Windows Updates, it asks me to install ActiveX and everything went smoothly on every single Windows XP machine I tried this on.

However, this method no longer works. I've tried it many, many times, but for some reason it no longer prompts me to install ActiveX and the update page always displays this error:
https://imgur.com/a/HsTpJMU

I've been trying everything under the sun, spending days trying each and every solution on the first 10 pages of Google, trying multiple search terms. It doesn't help that Microsoft never made a standalone ActiveX installer as that would probably solve this issue. Am I missing a step here?

Comments

  • Supposedly they changed all of the servers to require TLS 1.2 or something like that which isn’t supported on XP or Vista. I tried adding the TLS support that POS Ready adds, and it still wouldn’t work for me.
  • So is updating Windows XP impossible now? I need the latest updates for an important project.
  • Are there any updates at all added for XP?

    It used to be that the wsus offline update tool could grab all of the XP updates. But I hadn't grabbed a fresh copy in many years.
  • Not added, but I don't have any installed. As a worst case scenario I have a physical computer with a completely updated copy of Windows XP that I could use, but I'd rather use a VM if I can.
  • There is a lot of information in this thread:
    https://forums.mydigitallife.net/threads/restore-windows-update-for-windows-xp-server-2003.82538/page-2#post-1627233

    It seems like a lot of the things that worked until very recently broke, but keep checking back on that thread and maybe someone will come up with another workaround.
Sign In or Register to comment.