"This program requires Microsoft Windows."

I was using my Windows 98 SE virtual machine in VM VirtualBox and I tried to install Microsoft Entertainment Pack 1 on it through the disk image. However, when I ran setup in the virtual machine, it came up with the strangest error in the MS-DOS Prompt:

"This program requires Microsoft Windows."

I assume I'm using too later of a version of Windows, but I still need some help.

Comments

  • Launch the installer through Windows Explorer itself.
  • It could be that have corrupted the installer somehow.

    I don't know if current virtualbox still likes 720k disks. If you are mounting the images as a floppy, try using Winimage to convert to 1.44mb first.

    You could also try extracting the files with Winimage and then importing them in to the VM some other way (such as a network share). Although note that some installers require running from a floppy, hence why WinWinworld standardized on floppy disk images.
  • edited January 9
    It's a double win for everyone, to standardize on floppy disk images!

    VirtualBox still took 720k diskettes when I tried it last, but that was some time ago and Oracle in all likelyhood borked it.
Sign In or Register to comment.