5150 Model F vs Model M keyboards

My Model F keyboard is working fine. Just one of the stands on the backside is broken. I can probably fix it (replace with a 3d printed part), although it'll require taking the whole keyboard apart.

So I ordered a Model M keyboard, with a 5-pin DIN connector (detachable). It didn't work at first (it just typed garbage). I detached the cable and cleaned the connector and socket that it connects into. Miraculously, it started working - typed the alphabet, ran some programs, FTPd over some new software. [ the NUM LOCK/etc lights didn't work - but I noticed during reboots, all those green lights flickered at the same time ]

But after a few minutes, the 5150 froze (at DOS prompt). I rebooted, and saw "301" (keyboard) related error. And sure enough, the Model M would just type garbage or sometimes nothing at all. Hmmm..

I tried cleaning the connector again (hydrogen perioxide), lightly using a spray of compressed air to dry and remove any debris. The Model M works for a little while... Then DOS prompt eventually locks up (typically after pressing ENTER to invoke some command - then the cursor just sits there on the next line).

So..... This Model M has worked, but only for a few minutes at a time.

I've swapped back to my Model F, and that works just fine -- still working after hours of use.

If a particular Model M is compatible, will just work or NOT work right away (and indefinitely)? Or are there timing issues every now and then that might make the Model M cause the PC to freeze up? I noticed only sometimes when I booted with the Model M that I'd get a 301, sometimes not. If it's checking for what "mode" to run in, does it redo this check every so often during use?

I don't see any damage on the Model M detachable cable - but I suppose maybe it's possible some defect is in the cable itself.

I guess my question is: does a Model M ever work intermittently on a 5150? Or do they either not work at all, or work all the time?



  • I don’t think I’d use Hydrogen peroxide to clean connectors. It’s an oxidizer.

    I seem to remember a BIOS update being required for “enhanced” keyboard support on the XT and AT. IBM didn’t officially support the 101 key keyboards on PC as far as I know, but I’d still expect it to work.
  • It should work fine. What is described sounds like either a bad cable, bad plug, or perhaps a bad solder joint on the keyboard's PCB.

    If there is visible corrosion on the plug, you will probably want to replace the plug.
  • Thanks, I've ordered one of those new plugs that goes directly to USB - if it works on a modern PC, then I know the keyboard itself is fine.

    The Model F is so rugged, but the Model M layout is so much nicer....

    My 5150 is actually from '84 (it has the 63W power supply and tape cassette port, but it is a "Model B" that has the newer ROMs and 256KB onboard RAM).

  • Keyboard is working fine (in modern PC), all keys working and the lights. I ordered two types of USB adapters: one that goes at the end of the black pig tail cable (like 5-pin DIN to USB), and another that is a complete replacement of that black pig tail cable (plugs into the keyboard and goes directly to USB). Both of those work, which suggest to me that the black cable is fine also. And they both work reliably for over an hour of usage.

    So, if the keyboard and cable are fine....

    Odd that it works for a few minutes on the 5150, then starts to give garbage characters (wrong scan codes). Sometimes it would boot up with a "301" (keyboard error) and sometimes not. Maybe some timing/sync issue with the 5150. Next weekend maybe I'll swap in the V20 chip, see if it makes any difference (but isn't most keyboard handling itself in the ROMs?).
  • Does this "garbage" constantly occur after a specific length of time or a specific usage?

    I would still strongly suspect it is just an issue with the plug/connector. This plug might not like this specific socket - happens all the time. If you hold the plug in the socket tightly, does this still happen?

    Ideally, I would try a different keyboard cable.
  • Alright, if I come across another cable - but that might be awhile. I did try it again, and this Model M did work on the 5150 IBM PC for awhile - when it does start working, it seems to work until I reboot (basically if it boots with no "301" error code, then it is probably going to work). I'll get just used to the Type F original until I can find another cable to try.
  • If it’s got the removable SDL cable, you can get new ones in either PS/2 or XT/AT style from unicomp. I may have an old PS/2 removable cable too, but you’d need an adapter to AT/XT style.

    I’d still question if it’s fully compatible with a PC though. I’ve got a late XT model M and it’s the type with no LED.
  • Thanks, ok I ordered a new cable from unicomp. Ouch, shipping a bit expensive just for a cable. If that still doesn't work, then I'll hunt for a Model M that doesn't have any of the LED lights (the Model-M I tried is from 1991, so I'll see if I can get an earlier one).

    I've compiled notes on my IBM PC 5150 keyboard stuff at:
    (along with other 5150 related notes)
Sign In or Register to comment.