Windows 3.0 mouse issues

Good evening all!

I just found out about this site, and I registered to check if someone can help me with a little problem I'm having on one of my retro machines:

An old 386SX/40 with DOS 6.22 and Windows 3.0, I can't get the mouse to work on Windows, even tough it works fine on DOS programs and games.

It's a Mitsumi two-button serial mouse on COM1.

Here's what I've tried so far:

- Tried with in autoexec.bat
- Tried with mouse.sys in config.sys
- Tried with alternate driver in autoexec.bat
- Tried with alternate driver mouse.sys in config.sys
- MSD (correctly) identifies the mouse as a serial mouse
- Popped out the SD card with the OS and ran it on DosBox on my machine, and the mouse works fine (probably because it identifies as a PS/2 mouse, don't know).
- Running an image of the SDCard on PCem configured as an AMD 386SX-40 with a serial mouse, windows recognizes the mouse just fine.
- Tried changing the Mouse on Windows setup to "Microsoft or IBM PS/2 mouse" (the default) and with "Logitech Serial Mouse".

Nothing so far worked. I'm open to suggestions.

Thanks for your time and have a nice week!


  • Hmm, if it is working in DOS then that means the mouse should work.

    Windows uses its own driver, so any loaded in DOS will have zero effect.

    Despite the name, the "Microsoft or IBM PS/2 mouse" should work with serial.

    Try checking that your serial port is configured for the right I/O address and IRQ for use as COM1.
  • Also, you might try installing the Microsoft Mouse 8.2 Windows drivers here:

    This installs a newer Windows 3.0 mouse.drv file, and it should work with both serial and PS/2 mice.
  • "Try checking that your serial port is configured for the right I/O address and IRQ for use as COM1."

    I assume you're talking about the "Ports" section on the Control Panel. I'll check that, as well as trying out the driver you suggested.

  • Well, the "Ports" section on the Windows 3.0 control panel only talks about baud, parity and other modem-related items, so no ports or IRQs there - where (if somewhere) in Windows 3.0 do I check those? I skimmed win.ini and system.ini and couldn't find a thing.

    About the driver you suggested, installed it, and it didn't solve anything - it adds a program supposedly to configure the mouse, but it tells me that there isn't a mouse connected (and of course there is, as it works under DOS).

    Thanks once more.
  • I tried to add the lines COM1Irq=4 and COM1Base=3E8h (that I took from running MSD) to the [386Enh] section of system.ini (as instructed on a .txt file inside the Windows folder), but I didn't work - I assume that it was because, as I only got 1Mb on my system, it doesn't run in 386 Enhanced mode.
    But how to define these settings if not running in 386 Enhanced mode? *scratching head*
  • 3E8h? Yea, that's what I thought, your COM port is set to COM3, even though BIOS/DOS might be calling it COM1. DOS drivers can figure out a mis-configured port, but the Windows drivers are not that bright.

    Here are the addresses and IRQs each COM port should be set at:

    COM1 - 3F8h IRQ4
    COM2 - 2F8h IRQ3
    COM3 - 3E8h IRQ4
    COM4 - 2E8h IRQ3

    So what you need to do is change the jumpers or DIP switches on your I/O card (or motherboard if the port is on the motherboard) so it is set properly as COM 1.
  • Thanks for the tip. Will check that out tomorrow! Fingers crossed!
  • Thank you so much - that was it! Hope this helps anyone who gets the same problem as I did.

    Best regards!
Sign In or Register to comment.