PowerMac G4 troubles

A few years back I received a PowerMac G4 MDD 2003, and I still haven't been able to really get it working.

When I got it, the Mac OS 9 install on it kept freezing every few minutes. Unsurprising, considering that it was primitive even back then. (My PowerMac model also happened to be the last one that could come installed with OS 9, which is likely why it was purchased in the first place) I threw ancient version of Debian on there, and forgot about it.

In 2020, I then got a new SSD for it and 2 GB of RAM so I could actually do something semi-useful with it. The RAM didn't work at all, but luckily the SSD did. I then forgot about it again. Then last month I took it out again. I attempted to install the latest Debian unstable on it - but no luck; the installer kept crashing and I didn't know the cause.

Then I tried again with the latest NetBSD. To even boot the installer I had to go into OpenFirmware. What a pain in the ass. First, unlike the age old standard PC BIOS, or pretty much any real computer firmware made since around 1990, OpenFirmware is a command prompt. I usually wouldn't have a problem with that, but Apple, of course, never documented it. After over an hour of attempts, I managed to eventually boot into the installer using this section of the NetBSD installation guide. The installer itself was pretty dated, but usable. I did have to manually configure my IP address, but it surprisingly worked and could even download additional packages. I had been lured into a sense of false hope. After rebooting, I had to go back into OpenFirmware and that's where I got stuck. I pursued the web in search of help, but even the install guide got me so far. Eventually I found what might have been the correct command, but it kept bitching about "the load size is too small" or something. I booted back into the installer and got a shell to see if the install actually worked. It did, and I could even mount the SSD and load programs from it!

The closest thing to real documentation was this, but I still haven't gotten it to work. If I can't figure it out ever, I might just install the last stable version of Debian for PowerPC, and try to use apt to get to the current unstable.
Sign In or Register to comment.