[request] Help with 4th dimension 4.0.11 for Macintosh disk dump

edited December 2022 in Offers & Requests
I'm trying to dump a copy of 4th dimension database 4.0.11 for Macintosh in french and have trouble with one disk, "Programme 2"

There one bad track in the start of the disk and the content is not recognized. AppleSaucefdc shows a bad sector.
I nevertheless tried to make a copy of the disk and ran Norton Disk Doctor on the copy but even then the disk is not recognized.

Any chance to recover something from this disk ?



  • I'm not too familiar with the tool you are using. Can you post a flux dump in SCP or KF format? That is the only way to see what is really going on.

    You say you made a copy? What did you make a copy with? A real Mac? How did you work around the errors there? Most Apple copy program will refuse to copy a disk with errors.

    Do not try to write back to the original disk. That will almost certainly make things worse.

    As you are probably aware, Macintosh VBR GCR encoding can be very troublesome to read and decode. From my own experiences, usually the best approach is to try dumping with many, many, different floppy drives and eventually one may dump the problem sectors - but barf on everything else, making it critical to keep every flux dump so good tracks can be pieced together.
  • I used the AppleSauce fdc controller (https://applesaucefdc.com/), which is specialized into imaging Apple disks. Attached to it I have a Macintosh Superdrive floppy drive that can handle VBR GCR encoding natively. The software is very good, as it's able to retry reading bad sectors several times until it eventually succeeds (or not). Output format are Diskcopy 4.2 (DC42), IMG and MOOF proprietary format which preserves the original flux.

    I was able to dump the floppy in dc42, IMG and moof format and then create a physical copy of the disk using the same device. I tried to run NDD on my Powerbook G3 to scan this copy but it's not even recognized by NDD as a floppy to be analyzed.

    Trying with SCP is certainly worth a try, here is the file in SCP format https://mega.nz/file/fbolXBzK#0tvdqpftJq7w-kjYd5a8GX8j4Y6fMiE3miKnJ2N5iiA
  • Thanks. Not much luck with that SCP image, I'm afraid. I normally make flux "preservation" dumps for the first try just in case a disk rips itself apart - sometimes that can contain the best possible read even if some sectors are not fully decodable.

    So, looking at a plot tells me a lot...

    Notice how the bands are different from all other sectors. This isn't disk damage where you would see one big puff of noise, instead the entire sector content is off. Someone wrote back to this disk on a real mac with a faulty/dirty drive. Unfortunately, this probably the most common cause of behind borked Mac disks.

    Again, the nice thing about a flux image is it lets me TRY to decode the sector. It could just be a single bit that is off, and guessing the right value to match the CRC may restore the image with confidence.

    Unfortunately, all I get is gibberish. Either that is what is actually in the sector or the PCE tools decode the noise that way. I'm more used to working with MFM disks.

    So, anyway, looking at the disk structure, all that is in that sector appears to be an ID that tells MacOS that is valid disk, the volume lable, and the last used date (This is why the sector gets re-written), and a few other misc bits. Sooo.....a bit of copy pasting...

    See if the attached file gets you what you need. When I tried, it showed me the file on the disks and seemed to assemble it with disk 1.
  • wow ! it works ! As you mentioned, the file on disk 1 does assemble with the one you recovered on disk 2 and the program file is created correctly !

    Thanks very much for your help, it's really appreciated.
Sign In or Register to comment.