[offer] Sublogic Jet 1.0 for IBM PC [5.25] (SCP)

Here is Sublogic Jet 1.0 (I believe), for IBM PC.

I have some trouble converting it to IMA and run it on 86box. It has an unusual format.
Can someone have a look and do the conversion for me ?


  • edited January 16

    I also used to have this game ago.

    Your dump has no problem.

    But this game has disk copy protection track/sector just like Microsoft Flight Simulator 1.x/2.x

    It doesn't work with standard DOS disk format.

    At least It runs on PCE well.
  • Yes, the dump appears error free, and converts to a PSI file for use in PCE just fine.

    The software is copy protected, so it can not be saved as a standard sector image file (.IMG or .IMA). In this case, it is not even possible to create a reference image, as the program content, except for a DOS loader stub, resides in the protected area.

    The disk uses 1024 byte sectors on all tracks except for track zero.

    In this case the lowest common denominator that can hold the image appears to be the ImageDisk format (.IMD). Teledisk and Copy II PC+Snatchit should work too.
  • what pfi/pri commands are needed to convert this image from SCP to PSI ?

    Does it make sense that I also make a Teldisk and transcopy image or is the SCP sufficient ?
  • edited January 17
    Example :

    1) Run command prompt or terminal (with administrator)

    2) Make folder (directory) on C: or D: (I created it as JET)

    3) CD\JET (on C: or D:)

    4) Extract "Jet 1.0 [5.25].scp" on JET

    5) Rename "Jet 1.0 [5.25].scp" as disk1.scp

    6) Put pfi.exe pri.exe ps.exe on C:\Windows folder from PCE emulator.

    7) Run pfi.exe at first.
    -->pfi disk1.scp -L
    *In this case, RPM : 298.xxxx (Nearly 300 RPM). Track Range is 0-41.

    8) Run pfi.exe with this option.
    -->pfi disk1.scp -r 500000 -p decode pri disk1.pri
    *500000 is 300 rpm for mfm , 600000 is 360 rpm for mfm

    9) Run pri.exe with this option
    -->pri disk1.pri -p decode auto disk1.psi

    10) Run psi.exe at first.
    -->psi disk1.psi -L

    In this case, Track 30 / Side 0 and Track 31 / Side 1 contain unnecessary sectors. Please note that Jet Disk consists of a single side diskette, so only Side 0 is needed to run the game and Side 1 is not needed at all. .

    Of course, you don't have to touch the converted disk.1scp any more, but it looks good now.
    To finish, you can remove unnecessary sectors on side 1 by executing the following.

    -->psi disk1,psi -c 30-31 -h 1 -p delete disk1fix.psi

    This is an example of a basic and simple conversion method.

    I also use more diverse and complex conversion methods than this.
    They even use methods that are not in the PCE emulator's manual.
    Depending on the disk, it can be complicated and use multiple options.

    However, in order to make work time more efficient, I created several ,BAT files with frequently used options and just entered the file name.
    I'm doing this to reduce the hassle and shorten input time.
  • The standard batch file I use for converting double sided double density KF/SCP images contains:

    pfi [flux Image file name] disk1.pfi
    pfi disk1.pfi -R 1 -r 500000 -p decode pri disk1.pri
    pri disk1.pri -p decode mfm disk1.psi -f -v
    psi disk1.psi disk1.img
    psi disk1.psi -L > disk1.txt

    This creates a PSI, IMG (won't be useful in this case), and a TXT file containing a list of all sectors it found.

    The command
    psi disk1.psi disk1.imd
    will output an Imagedisk file. In this case the ImageDisk file is complete, so there is no need to actually use ImageDisk to read the disk.

    The SCP dump appears complete and sufficient. The only reason I would create a Transcopy dump is for those who wish to write an image with a Transcopy card - the last time I tried, converting a KF or SCP to transcopy did not work very well.
  • @SomeGuy and @ibmpc5150 thanks very much for your help. I created disk1.psi and disk1.imd
    But then I have problems using those images to boot using PCE

    This what I try to do:
    • I launch PCE : pce-ibmpc.exe -v -c pce-5160.cfg -l pce.log -g cga
    • in debug windows I type : m insert disk1.psi (or m insert disk1.imd)
    • and then g
    The emulator runs but I have an error 1701 and it loads basic

    I'm really not confortable using PCE, so there's probably something I'm doing wrong here.
  • edited January 19
    In my opinion, it seems to be a compatibility issue between PCE emulation and IBM PC 5160 BIOS (01/01/1986 or 05/09/1986).
    I see it.
    I've contacted Hampa in the past and it doesn't even support 5.25 1.2MB drives on PCE.
    He said it was not officially supported.
    In this case, the problem is that the 160KB/320KB format diskette cannot be read.
    However, diskettes in 180KB/360KB format are read normally.

    Therefore, to solve this problem, do not use BIOS (01/01/1986 or 05/09/1986) but replace it with BIOS (08/16/1982 or 11/08/1982).
    I have no choice but to use it.

    The conclusion is that it is a compatibility issue with the PCE emulator + the two BIOS above.
  • The newer IBM BIOS causes an error with this software? Ouch.

    I'm using a slightly older version of PCE with the ibm-xt-1982-11-08.rom, and it worked OK for me. I launched the program from a 10mb emulated hard drive running IBM PC DOS 2.0, but I think the Jet disk should also work as a booter.

    Yea, PCE is very un-userfriendly. But it has extremely accurate emulation, especially involving the floppy drive and copy protection.
  • Since PCE is not a GUI-based emulator, it cannot be used without some understanding of environment settings or execution settings.

    I create dozens of files, including a .cfg file that stores various environmental settings for the corresponding model and a .bat file to easily execute them, and execute them according to the situation.

    It may be a bit of trial and error at first, but once you create and run the environment settings and batch file properly, you can run it by clicking through the batch file without much need to modify or add anything.

    In the case of the GUI method, it is convenient to select the model or run it, but if there is no batch file or file with saved environment settings, it is inconvenient to change it in the menu each time it is run.

    Nevertheless, PCE is even more difficult to use unless you are a user like me who knows a certain amount of commands or how to edit environment settings.
  • @callmejack
    Here is Sublogic Jet 1.0 (I believe), for IBM PC.

    I have some trouble converting it to IMA and run it on 86box. It has an unusual format.
    Can someone have a look and do the conversion for me ?

    Sure. But converted to IMA image won't work due to obvious reason - non-standard floppy format. But this booter works without problem after conversion to modified MFM or 86f format. I tested it on IBM XT (1986) config with 360k FDD A: and CGA gfx card (the game won't work on EGA and newer cards):

    Here are attached floppy images in MFM and 86f formats, both have been tested and working:

  • @SomeGuy @callmejack

    According to Hampa, the problem is on IBM PC-DOS 3.20 / 3.30 with 160KB/320KB disk.
    (MS-DOS 3.20/3.21 has no problem, but MS-DOS 3.30 has problem.)

    There is no problem on under IBM PC-DOS 3.10 or MS0DOS 3.21

    IBM PC-DOS 3.20 (MS-DOS 3.30) and later require a proper boot sector with a bios parameter block.
    The Jet disk does not contain a DOS boot sector with a bios parameter block..

    So, the best option is to use IBM PC-DOS under 3.10 or MS-DOS 3.21
    Or, use old bios of IBM PC XT.

    Another solution is to boot directly from the jET disk.
  • thanks @ibmpc5150, I tried with predefined "PCE Ibm-pc-pcdos-1.00" machine and it works fine !
  • @tarlabnor what's the .cfg file that your're using ?
  • edited January 21
    The one in attach (just rename it to .cfg)

    p.s. VM with this config has IBM DOS 2.10
  • Is there a label scan I can put with this?
  • New version of PCE is updated.

    Author added another pce5160 (IBM PC 5160 with 11/08/1982)
  • edited February 1
    @ibmpc5150, @SomeGuy oh yes, I forgot to post the link to the full package, with artwork and scan of the manual :
  • @tarlabnor thanks for sharing the config !
Sign In or Register to comment.