Qt3 and the ./configures

QQ
edited April 2004 in Software
Whenever I try to compile a KDE app (Fairly common), I get told that Qt isn't installed, but it IS!

SuSE installs Qt to the ./qt3 dir, and the RPM entry is qt3-3.whatever, not qt-3.whatever.

As a result, all ./configures will fail on this.

Any helps? I'll post the errors and any log files if needed/

-Q

Comments

  • NM, I've figured it out.

    I have to specify --with-qt-dir=-/usr/lib64/qt3 and --with-qt-libraries=/usr/lib64/qt3/lib64

    -Q
  • Well then, problem solved.
  • You can also export 'QT_DIR=[whatever]' in your ~/.bash_profile or /etc/profile. That way, configure will find QT most of the time, and you won't have to bother typing the --with-qt-dir deal.

    I forget as to whether QT_DIR is supposed to point to the .../lib directory, or the root of where QT is installed in general.
  • The root, theres a seperate option for the libs dir.

    -Q
Sign In or Register to comment.