Ess AudioDrive 1869 joystick problem under DOS

edited June 2017 in Hardware
I have a strange issue with the joystick port on my Ess AudioDrive 1869 ISA sound card. When running DOS, I can get sound just fine but the joystick does not respond. It'll work under Windows 95, but not DOS or DOS mode.

Just in case it could mean anything, this is the line in my AUTOEXEC.BAT file:

Let me know if this isn't enough info or if you have any suggestions.

Any help would be appreciated.


  • I have the ESS1869 ISA card in my Digital PC 486.
    Sound was fine using SBPRO drivers, but the game port was not working.
    The ESS drivers were required to get the game port enabled in Dos.

    You can DL the DOS version from: ... /?id=11115
  • edited June 2017
    Already tried the DOS utilities. Just prints this error message.
    ESSCFG Version 5.1
    ES1869 configured by PnP BIOS or ICU, commandline parameters ignored.
    Audio      IO:220h IRQ:1 DMA0:1 DMA1:1 MPU401:303h

    Tried to set it up as per the readme, but got that message. Stupid part is it also "ignores commandline parameters" when all you want is the built-in in help.
  • You need to place the file in autoexec.bat:
    [path]esscfg.exe /A:220 /I:5 /D:1 /J:E !

    The /J is E to Enable or D to Disable the Joystick Port
    You MUST place the "!" at the end of the line to allow settings to change.
  • No go. With the exclamation point at the end I get this error:
    ESSCFG Version 5.1
    Unable to find AudioDrive ES1868-based chip!
Sign In or Register to comment.