Software Spotlight: Citrix Multiuser 1.0 MS-OS/2

edited October 2016 in Software Spotlights
In the early 1990s businesses were increasingly trying to move from mainframe/minicomputer solutions to those that could be hosted on desktop PCs. But getting a computer on every desk was very expensive, both in costs of initial expense and maintenance.

An interesting mid ground of sorts could be had by connecting inexpensive, and often existing, dumb terminals to one single beefed up desktop microcomputer, and sharing applications.

Unix solutions could be found, but at the time those required very expensive software licenses, usually very expensive proprietary hardware, and exceedingly high development and maintenance costs. Essentially throwbacks to the minicomputer. Various multitasking DOS solutions existed, such as Digital Research Concurrent DOS 386, PC-MOS, and VM/386. But... well, DOS!

Again, a midground was IBM and Microsoft's new OS/2 product, which evolved from Microsoft's earlier attempts at making a multitasking DOS, and was to be the successor to DOS and Windows 2.

But OS/2 was only a multitasking OS, not multi-user.

Until Citrix Systems came along:


Released in 1991 by Citrix Systems, Citrix Multiuser is a customized version of Microsoft OS/2 1.21 that turns it in to a real multi-user operating system. With Citrix Multiuser, users can connect and simultaneously run character cell based applications from remote serial terminals. To prevent users from interfering with each other, it adds security permissions to devices and files. It can use multi-port serial port boards like the Digiboard, or any serial device that has OS/2 1.21 drivers.


An interesting promotional video is on youtube, that shows how it could be used:

And a 1991 byte Magazine review is here:

Citrix Multiuser OS/2 does *not* support running Presentation Manager based application or DOS executables, and programs can not use graphics modes. It also does not have support for networking. (it looks like you can install LAN Manager, but it won't use that for communications.) Another limitation is that text-mode applications can not use a mouse.


Although it can not run DOS applications, many familiar text mode DOS applications had already been ported to OS/2. A few examples include: WordPerfect, Lotus 1-2-3, Microsoft Word, HyperAccess, Oracle, Paradox, and R:base.

Unfortunately for Citirx Systems, this product was released just days before the IBM-Microsoft separation, which was an almost instant fatal blow as Citrix was licensing OS/2 code through Microsoft.

As a result, Citrix Systems had to backtrack and instead focused on making MS-DOS multi-user until eventually they released a Windows NT based version.


Installation was a bit of a headache -

To install on a faster computer, you must first apply the OS/2 speed
patches described here to the boot disk: ... ualbox-vm/

To summarize, replace all occurrences of:
B8 F4 01 BB C8 00 F7 E3 F7 F1
B8 F4 01 BB C8 00 F7 E3 90 90

It currently will not install in PCem (or some real hardware apparently) due to a known bug with OS/2's FDISK. Unlike normal OS/2, Citrix Multiuser's setup will not let you skip that.

The CSD update disks must be installed from maintenance mode. To do that, use the Citrix Multiuser OS/2 boot disk, and after install starts from the second disk, hit escape.

I managed to get it running in VirtualBox 4.x. Fortunately VirtualBox will accept either 1.2mb or 1.4mb images and they "just work". When I initially tried to resize the install images to 1.44mb using WinImage, it didn't seem to like that for some reason. There is probably some way to convert those or perhaps I just did something wrong. Otherwise, with other emulators you might have to check and configure 1.2mb disk support. On real hardware you can write a 15-sectors 1.2mb image to a 3.5" disk but you have to make sure the disk is formatted properly. The Corrective Service Disks are on 1.44m disks.

This also includes "Multiuser Link", a telecommunications program that Connects a PC
running DOS or OS/2 to a Citrix Multiuser system via standard RS-232C serial directly or with a modem.


This provides some extra optimizations not available with other terminal types. It supports ZMODEM file transfers, dial-up and direct connection, SSA/CUA compliant menuing user interface, context sensitive help, ICA (Intelligent Console Architecture) and ASCII terminal emulation, full color and sound, and local PC printing from the Citrix Multiuser host.

In conclusion this is an interesting and, in its time, potentially useful application built on a stripped-down version of OS/2.


  • Hmm, would have expected the OS/2 fans to be all over this by now.
  • Did you notify Michal at the museum?

    Personally, I'm looking for WinFrame (or even MetaFrame...) licenses.
  • Thanks for sharing this program.

    Disk 2 seems to be modified. (I fixed (recovered) the image)
    But this program runs on OS/2.
    I'll try to install this program when OS/2 is ready.
  • Wow this is totally cool! I'm going to have to find some way to get this thing going. It's so awesome someone finally managed to get this thing out there, I've been looking for YEARS.

    There should have also been an OS/2 2.0 style product to run multiple MS-DOS sessions and whatnot. Before they had their Windows NT 3.51 based product. I had no idea it didn't support named pipes or anything like that, but it seems very little of that era really had networking in mind.
  • I finally got a chance to re-install this, and trying to install the CSD's left me kind of lost. The disk images seem to not be right, chkdsk see's tonnes of missing sectors.

    I can't find any source on any CSD's for any of the OS/2 based Citrix stuff. Any/All pointers would be most welcome!

  • The CSD disks worked OK for me.

    The CSD update disks must be installed from maintenance mode. To do that, use the Citrix Multiuser OS/2 boot disk, and after install starts from the second disk, hit escape.

    Keep in mind though that the posted CSD images are 1.44mb and the boot disk is 1.2mb. I don't know how they managed to use that on real hardware. Switching between 1.2mb and 1.4mb disks at runtime will confuse the hell out of some emulators/VMs. You probably need to convert the 1.4mb disks to 1.2mb with WinImage.

  • edited November 2017

    I figured it out, okay so hit escape to get the CMD prompt, then swap in the CSD disk #1, and run install. I was thinking for some reason it'd pick up the installer program on it's own or something.

    Citrix MULTIUSER Operating System, Version 1.0
    Standard Edition 1.21 Component ID
    Current CSD level: MU01091
    Prior CSD level: MU01064

    MS OS/2 Base Operating System
    Standard Edition 1.21 Component ID
    Current CSD level: XR04072
    Prior CSD level: XR00000

    So now I'm 'patched up'

    Now I just need to figure out what is up with the serial ports and not allowing me to hit enter.. I should just install that link program thing I guess.

    Also since you have some info on this stuff, I have a boxed copy of 2.0 that I'm just waiting for a drive to image them, do you have any CSD's for 2.0 by any chance? or any hint on where to get WinView the OS/2 + Windows version of Citrix?

  • The only stuff I have is for 1.0, and all of that is posted here. Early Citrix is rather obscure. If you can dump your 2.0 disks and/or scan the manuals, please do send them in!

  • edited November 2017

    Im slowly going thru the material.. I think my new 5 1/4" drive will be here in a few more weeks so just have to patiently wait.

    Going through the manuals though, this would be Microsoft OS/2 2.0 the un-released version with MS-DOS support. it's all text mode at this point though. I'm really wondering if it'll run any 32-bit OS/2 programs, but I suspect it'll be the LE format from the older Microsoft OS/2 2.0 beta. At least the SDK is in the wild, but the beta versions of OS/2 that were recently found are under some 'no share' thing for some reason. it's a shame.

  • Got the drive, dumped the disks! Amazingly no read errors! ... No idea how to upload though here.

  • Yeah, I really need to work on the contributions system, but other hobbies and duties keep taking away from that, along with my quest for doing it the right way, whatever that is.

    Until then, you can upload it on a file host and give us the link; admins can still manually upload files to mirrors and add them to the library that way.

  • Yup, I got his contribution manually and it's in the library now. Need to sort out metdata, but it's there!

  • I LOVVEEE OS/2! I am an OS/2 freak!
    But I don't have old enough hardware for these things.

  • @HorseBatteryStaple said:
    I LOVVEEE OS/2! I am an OS/2 freak!
    But I don't have old enough hardware for these things.

    @HorseBatteryStaple said:
    I LOVVEEE OS/2! I am an OS/2 freak!
    But I don't have old enough hardware for these things.

    I'm secretly trying to put together a killer 386 DX machine, but in the meantime Citrix runs in Bochs!

  • What date was this released?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file