Weird SCSI Issue - DOS

Hi all,

New around here. I've been building a franken-scuzzy machine and ran into a rather unusual issue. I have a Fujitsu MO drive, that when under BIOS control (Adaptec 29160N) and mounted as a hard disk, I get messages about files not being found and then a prompt for the command interpreter location. This occurs immediately after the Iomega ATAPI ASPI driver loads (set to scan Secondary IDE only). When the MO is skipped by BIOS and controlled by ASPIDISK.SYS, no issues. Has anyone ever seen weird behavior like this? It happens regardless of MO media used.


  • It may be presenting a different geometry to the DOS system. Of course, SCSI stuff is all LBA so SCSI cards have to pull CHS number out of the air. I'd try viewing the Physical disk with something like Norton Utilities and see what it has to say.

  • I'll give it a shot. I actually was just loading Norton Util v8 onto a zip to transfer it over. I'm just wondering why the geometry would change. Maybe an all or nothing thing--having one device over 1GB causes translation for all attached disk drives.

  • Tried it and Disk Doctor locks up on launch, but I think I know why. I have an NTFS disk on IDE-primary (has to be present or the Zip ATAPI driver freezes on load).

    I tried turning translation off on the SCSI BIOS, and no luck.

    I wonder if the ATAPI driver is just stupid and thinks the MO is a Zip or something.

    Any other ideas?

Sign In or Register to comment.