My notes about ComputerHunter

edited July 2020 in Software
Hiya! I did see ComputerHunter's post on my "rumor".

Some pictures, as always.

How I successfully ran Windows Alpha on MS-DOS 5:

- I installed a mouse driver. Notably from the MS-DOS 5 early releases (not for the public, alpha/beta releases), there is a mouse driver pre-installed.
- Drivers. EGA was in that list. VGA is fully compatible with EGA.

I tried to install DR 5, but this is the best picture I could get. Nice one.

It successfully ran with a patch to update the mouse driver to do with 16h. I could move the cursor around.

I know about the Notepad glitch, it's about DR 5, I'm pretty sure. But just in case:

Here's some apps running on my VM.

Minimizing MS-DOS Executive.


One problem with closing: the Windows GUI does not close. The black font is here, making text unreadable from the console.

Hope that helps.

Note: I don't know what catergory to put this in. Please don't ban me.

This has been done before.

Wait; new luck for DR5 with the drivers


  • Yea, its not "news". Moved to Software.
  • OK, I don't think you understand what I said on the other topic so let me explain to you again.

    First thing first, why would you patch the mouse driver to use int 16h? It is a mouse driver, not a keyboard driver! jb881122's patch did not involve int 16h so if you patched a mouse driver to use it, I can guarantee you it will not work.

    Secondly, Incompatible DOS version does not mean the version DOS reports is wrong, I can have a copy of MS-DOS 2.11 and still get that error. It has something to do with the complex DOS environment check the Windows kernel performs upon boot. If you have MS-DOS 5, it will not pass the checks therefore you get the message but they are not fatal errors as you can see that no matter what, it all jumps to the same place. If you hate to see the error message, PM me and I'll patch the Windows kernel to skip the DOS environment checks.

    You are just lucky that you can bring MS-DOS Executive up but that does not mean it will work on every other environment and every other computer. Sometimes, when your DOS or drivers are incompatible, Windows can still boot but MS-DOS Executive will simply not load. It happens very commonly on DOSBox which simulates MS-DOS 5. It can also happen with incompatible drivers such as homemade mouse drivers or badly patched video drivers.

    As for the screen not clearing problem, use Beta Release's WIN.COM to start Windows (you can also have a nice boot screen that way). If you just want to clear the screen and make all text visible, just type CLS and press enter. I have attached a patched WIN.COM that addresses the issues with graphics remaining on screen after quitting Windows and it is NOT something official, it was modified by me.

    Lastly, I do not have anything against you but I do like to point out that 1) it is not a news that Windows 1.0 Alpha Release can run on VMware or VirtualBox 2) the DMAADD error does not have anything to do with the DOS kernel version 3) it will not run on MS-DOS 5 as stable as on MS-DOS 2.11 or 3.00 4) jb881122's patch involved int 33h, not 16h.
  • I meant int 33h.
  • Yes I did, I made another virtual machine and tried to re-install Windows Alpha and the MS-DOS executive didn't load. Also, I said "16h" because at that time, I was like this.
  • Now closed. Do not comment anymore!
Sign In or Register to comment.