Screwed by RH9 and laptop

edited April 2004 in Software
OK- As I posted previously, I put RH 9 and XP Pro on my Dell Inspiron 5150. It has a nVidia GeForce FX Go5200 graphics card and a 15" SXGA display. I usually have it at a resolution of 1400 x 1050. It works well in Windows.

I got Linux all installed, left it as Unprobed ( :lol: ) monitor and booted it back up. GRUB came up asking me whether I wanted RH 9 or "DOS" (which is XP Pro). I selected RH and continued the startup. All the text line stuff ran and then it goes to a blurry, usually pink or teal screen. I've seen this before when I set the resolution on a desktop computer at 800 x 600 when the monitor could only support 640 x 480.

This scrambled display on my laptop is most readable at 640 x 480. I found that if I shut the lid of my laptop, then open it again, it is no longer scrambled. It's just that the resolution is way messedup, and much of the screen is hanging off. The whole system works perfectly if I hook it up to an external monitor. In the config file in \etc it has the vid card correct. I found a driver at Nvidia's site. I downloaded it and trying to get it into a partition that Linux can see. I haven't even tried to get Linux to detect my wired or wireless network cards.

Any suggestions as to what I can do? Would Mandrake do a better job of this? I also have SUSE linux....somewhere.



  • In the command prompt run XF86config and set your monitor as a Generic Super VGA 640x480 and it should work find after that.
  • Well, it works. Finally.

    After almost wanting to say F*** IT to Linux and spending nearly 12 hours getting this, I got it. Here's what I did:

    Well I tried nearly every res and color depth, to no avail. I went to the Nvidia site and download a driver for my card. Except being that I haven't even tried to get the wired or wireless cards to work in Linux, I downloaded it in Windows and couldn't get a partition to be read by both sytems. I'm sure there's a way, but I just couldn't get it at that time and felt like it would take too long. Keep in mind that I'm a major Linux n00b, used it once, but the hard drive it was on was killed in an unfriendly way. Instead I spent the next 4 hours or so trying to mount the cd I burnt it to and run the driver. In the X Windows environment, I had no problem mounting the cd drive (I really think that phrase is so very disturbed... it just jives with TCP's old avatar). So after <b>mounting</b>, I ran the driver. I had just been yelled at by many not to be using root. So this time I had logged in as Adminsitrator. Nvidia wants root. Ugh. Log out. Log in. Run the damn driver. Now it doesn't want to be run in the X Server environment or some shit. So I ask around, and try to run "konsole", etc. Unfortunately konsole won't do it cause it's still in the X shit or something. So I logged out and went into failsafe and default (with the help of others). Sadly, they both were still running the X shit. Then Q helped me out.Dr. Ping and Warp were also quite helpful, as were still others. He helped me get into the old school command prompt. I had to hit Alt something. Then I was supposed to type kill x. But X didn't want to die, so we restarted it and hit I for intereactive startup and Q told me which service to allow and which ones not to. Eventually, I got into it and ran the driver. This was only after figuring out how to mount a drive in command line. (Thanks again, Q.) Then, I restarted. It still spazzed out. After closing and opening the lid of my laptop, I went to Display settings. I went to the graphics card and hit probe card. Previously, I did not want to put my card through the pain of being probed by the guy in the little red hat. But this time I had no choice. Actually, I had tried it before and I said it was some VERSA generic that I didn't think would work. Sure enough, it did work. So thank you for all of your help to all of you: Q, TCPMeta, Dr. Ping, Numbers21, Mr. Clean, DuffDude, No Nothing, and everyone else!

    Now I must go on a 12 hour crusade to get my ethernet and wireless card working.
  • HeH, glad you survived your tech trial. It's annoying when something screws you and places you in a catch22 encapsulated in an enigma.


    PS. You're welcome, I think. ;)
Sign In or Register to comment.