Windows 1.0 Alpha

13

Comments

  • @msdos6000 Do you still remember how you got the crash message to appear? The crash message is one of the mysteries in early Windows and all we know right now is it happens while MS-DOS Executive is loading (after failed creation of DiskWindow, PathWindow or DirWindow).

    I can of course replicate it with a simple patch but I would like to know how you managed to trigger it.

    Here is how the check works but we don't really know under what condition it happens.

    something = CreateWindow( parameters ); /* DiskWindow */
    *(int *)&variable = something;

    if (something == 0) {
    CrashMessage(); /* Windows is about to crash */
    }
  • edited August 15
    @ComputerHunter

    Well, I'm not sure. I just upgraded from MS-DOS 2.11 to MS-DOS 3.10-and got that message while starting Windows.

    Edit: Actually, I upgraded from these two versions: Toshiba branded MS-DOS 2.11 to Olvetii branded MS-DOS 3.10
  • edited August 15
    How much RAM and did you use? Is it possible to get it again with the exact same machine config?
  • edited August 15
    16MB. I'll try it again, and see if it shows up again. If it does, I'll send you a 7z file with it.

    EDIT: Probale 4MB. I forgot, but it can be either of these.
  • 4mb is a lot so low memory shouldn't be the cause. If those 3 child windows are fine (unless there were too many windows opened and it ran out of handles), then probably the LocalAlloc part messed up.
  • Oh ok. I'm thinking the LocalAlloc part is messed up as I didn't open up too many windows
  • edited August 15
    Definitely very stable on MS-DOS 3.10
    This is similar to "Windows is about to crash", but uh it crashed before it could display the message.



    Edit:

    And a video if you want to see how that came up...
    https://mega.nz/file/qQ01XDoY (Key: 6aPR1Ik1ZUSqXaWGkEJGGcj43mD99xrwNlTJVq2Geno)
  • edited August 18
    @ComputerHunter Can you share your compiled MS-DOS 2.11 img files?
  • I included the files in the VM I made. I can't remember if I hex-edited another OEM's DOS BIOS or linked 2.11's SYSINIT and SYSIMES with the generic skeletal BIOS from MS-DOS 2.00 OAK. You might have to make some changes but I can't remember what I did (RE_INIT related?).
  • I tried to install Windows 1.0 Alpha on pc-dos 3.00, but it takes forever to format pc-dos 3.00. Is it really formatting?
  • edited August 20
    @vio08
    Don't think so. Happened to me on MS-DOS 2.11 (other than Toshiba). Maybe its because of the hard disk format?

    EDIT: It locks up.
  • What disk size did you use? Probably not the best option to use a 2gb disk for a normal MS-DOS installation. Also, VMware will have problems with early DOS and Windows so I'd use 86Box or PCem if I was you.
  • I'd say just any size. Any size locks up on VMware (on PC-DOS 3.00). In my case it is a 32MB (or 16MB) disk.
  • Windows Alpha does not like MS-DOS 3.10

  • I'd recommend using IBM PC-DOS 2.1, although partitioning and formatting can be done with later DOS as long as the partition is FAT12 (16MB or less) because that is all DOS 2.1 supports.

    Random OEM MS-DOS releases were not likely as well tested, if tested at all.
  • edited August 21
    @SomeGuy



    Cool it worked
  • edited August 21
    @SomeGuy

    One problem I've had with certain DOS versions (OEM versions) that simply say the system was transferred, but if you take out all diskettes, and reboot it simply hangs (blinking cursor). Why I think it hangs is because if you press CTRL+ALT+DELETE (shortcut for restarting), it simply does not do anything.

    Great... just happened again (PC-DOS 2.10).


  • That means your hard drive screwed up. Normally happens when invalid code gets executed. Check if your boot sector is valid (especially BIOS parameter block), check if IO.SYS (IBMBIO.COM) is the first file on your partition, check if MSDOS.SYS (IBMDOS.COM) is the second file on your partition and check for corruptions.

    Sometimes older DOS BIOSes does not work properly on VMware or VirtualBox because they make a lot of assumptions about your hardware.
  • edited August 28
    End session normally doesn't clear the screen, but I got this:



    First, this is on IBM PC-DOS 2.10.
  • I am pretty sure I have provided a solution to the screen not clearing problem a few days ago. I have no idea how you managed to get black on blue without patching. My best guess is fast boot was still very primitive when Alpha Release was compiled so Microsoft did not bother about setting the video mode right when you end the Windows session. Well, mode 0Fh shouldn't give you blue graphics anyway so I guess your emulator does not emulate EGA perfectly.

    Why is it blue? Because 01h in the EGA palette corresponds to blue:



    This means if we patch the driver, we can get black on other colors. If you want eye cancer, then go ahead and patch the display driver.





  • @ComputerHunter
    Well, that certainly helps me better but I was using VMware Workstation.
    I am aware of the situation of screen not clearing!
  • @ComputerHunter That last screenshot will give me nightmares, it looks like it came from the depths of hell.
  • edited August 30
    This is the real nightmare:
    1200x800 resolution


    42x140 resolution


    Failed dark mode patch



    Beta Release glitches:



  • @ComputerHunter
    Oh, that looks so good. (means so bad)
  • @ComputerHunter
    Looks like you changed the graphics card and replaced it with a paper shredder.
  • @ComputerHunter
    Yay! Now I can run Alpha on my 4x4 monitor!! (I don't have it, it was a part of a joke)
  • @Koshgnintan
    Yeah, it certainly looks like it was replaced with a paper shredder.
  • Please note that 6000dosms, jackjones101567, Lollipop, and msdos6000 are all the same user.

    Please pick ONE account for posting.
  • I thought 6000dosms was msdos6000 second account. But it seems like he has multiple accounts.
  • edited September 4
    @msdos6000
    How did you install MS-DOS 3.10? I can't install it!
    ---My video installing it---
Sign In or Register to comment.