hDC ClickStart - Attempting to Copy

I recently picked up a copy of hDC's ClickStart for Windows 1. It was totally sealed and unused, but the box is not in the best of shape. I decided to open it up and see if I could image the disk. The disk looks absolutely perfect, but I am having issues getting anywhere with it. I encounter a read error just trying to switch to the disk. I tried to use DskImage to get a quick idea of if anything was readable, and noticed an interesting pattern. Sectors appeared readable except for sector 1 and sector 2 of each track. This was consistent for each head across all tracks. Sector 1 produces a CRC error, and sector 2 gives a sector not found error.

Since I am new to archiving and imaging disks, I am unsure if I am doing something wrong, or if the disk is genuinely unrecoverable. Any advice would be greatly appreciated!


Comments

  • Nice find!

    From what you describe, what has likely happened is that the surface of the disk that was exposed to the air through the jacket opening has gotten dirty and damaged. That creates an entire line of damage along the same sectors.

    Unfortunately, letting that run through a drive without cleaning has likely made the damage worse - this is why (after cleaning and inspection) I normally start with a flux level dump, that at least gets all possible bits and allows some reconstruction.

    I think this is going to be a tough one, but let's start by inspecting the surface of the cookie. Take a flashlight, shine it at an angle to the disk cookie, and see if any scratches or dirt become visible. You will likely have to try various angles. Carefully turn the disk cookie using the hub, and repeat until you have looked at the entire surface on each side.

    Is there a dirty area on the cookie shaped like jacket opening? Are there deep concentric scratches anywhere? Are there splotches, dents, scratches, or other damage? Often these are not visible until light hits them at the correct angle.

    I think this is an important enough title, if you are new to archiving stuff, you might actually want to set this one aside until you get more experience. (Or you could send it to me to try and dump).

    If you dumped it with DskImage then you at least got something. If you post that for us to take a look at, that could yield clues.
  • Here are a few photos of what I am seeing on the surface. This is the only thing I notice at the moment. It is a line that runs diagonally from as far inside as I can see towards the outer edge of the disk. It stops short of running the entire length.


  • A diagonal line like that would be a manufacturing-time artifact, and usually should not cause issues. (But I have seen a time or two when it has, because the software vendor didn't verify the media)

    From those photos, the surface does not look too bad.
  • edited June 30
    The best way is to dump it by SCP or KF.

    But if you have real DOS PC, I recommend to use DCOPY.EXE

    www.msxarchive.nl/pub/msx/utils/othersys/dcopy.zip

    Example :

    DCOPY A: DISK01.IMA /R:10

    (R:10 --> Retry with 10 counts.)

    Also TELEDISK 2.1x is good for dump.

    http://omolini.steptail.com/mirror/www.classiccmp.org/dunfield2/img54306/teledisk.htm
  • Thank you both for the suggestions and the info. The disk surface is very clean to my eyes. The disk was in its original envelope, unopened. I can't find any signs of dirt near or on the disk, but that is just my eyes. I don't doubt I could miss something.

    I would be willing to let someone else handle this one before I go further and reduce the chances of recovery. I do keep my drives clean and and good order, so hopefully I haven't damaged anything so far.
  • edited June 30
    Thanks.

    Unfortunately, The diskette's contents are most likely lost due to a change in magnetic force.

    Every sector 1 of track : data read error : Bad CRC
    Every sector 2 of track : data read error : Sector ID bad or not found

    The pattern of read errors is that all sectors 1 and 2 are regular.
    First, after cleaning the drive head, then would you please try to dump by DCOPY.EXE?

    DCOPY A: DISK01.IMA /R:100
    (R:100 --> Retry with 100 counts.)
  • Those errors are far too consistent to be regular damage.

    What kind/model/make of drive are you using to dump this disk? And what kind of computer system?

    I'm thinking trying a different drive might be beneficial in this case. If you are using a 360k drive, try a 1.2mb or if you are using a 1.2mb, try a 360k drive.

    Be sure to sanity check your system. Find a known good disk and make sure it dumps 100% correctly before trying this disk again.
  • I'd just like to note that according to PC Magazine's article on ClickStart from December 1987, ClickStart wasn't copy protected. It's unclear which version exactly was looked at, though.
  • I've been diverted from looking into this for a few days. I plan to get back to it soon. But at the moment I have tried it in two drives, a 1.2mb drive connected to a 486 running MS-DOS 5 and a 360k drive connected to a turbo XT clone, also running DOS 5. I will look into the specific models soon, but either way I am seeing the same behavior.
  • What I would try at this point is using a q-tip with a bit of water, not alcohol, and gently wipe off the area where that line is, noting if there is any visible change. However if this is really a manufacturing defect, then I would not expect anything to change.

    When the drive is sitting reading a track, do you hear any kind of "tick-tick-tick" noise from the disk?

    If you have not already done so, you might just try using DOS to copy the files directly off of the disk. Although in this case, I would not expect that to be much more successful.

    I'm thinking the only way to get more off of this disk would be to use a Kryoflux, SuperCard Pro, or other flux-level dumping device. That should at least retrieve some of the bits from the sectors that can not be "found". But I have a suspicion the errors would be too large to reliably recover.
  • If it's a floppy drive problem, try dumping it to another diskette and you'll find the answer.

    I have been dumping tens of thousands of disks for a long time, but in general, I see a high possibility that this type of track/sector read error is lost due to a change in the magnetic force of the diskette.
  • @oneadamtwelve, I'd just like to encourage you again to eventually get this disk dumped with a Kryoflux or similar flux-level device. (I'd be more than happy to do so if sent to me)

    I was thinking about this again as I was archiving some damaged disks here - a regular PC floppy and disk controller constantly returned errors, yet Kryoflux plus the HxC software was able to decode it with little trouble.
  • I agree, it's worth giving it another try, as this is a pretty rare and interesting piece of software.
Sign In or Register to comment.