Windows 2000 Modernization Tips



  • edited June 2019

    @win32 said:
    Ethernet or WLAN? WLAN requires a client not bundled with the OS, which is linked in the first post.

    Does it look good in device manager?

    Its called Ethernet Adapter, under Other Devices in device manager.
    I also cant get any sound.

  • You probably have HD audio, so try KB888111. It can't be installed properly after USP5.1 (slipstream only) but I think it will work after installing URP1.

    And try this for ethernet (Realtek RTL 81xx):

  • edited June 2019

    @win32 said:
    You probably have HD audio, so try KB888111. It can't be installed properly after USP5.1 (slipstream only) but I think it will work after installing URP1.

    And try this for ethernet (Realtek RTL 81xx):

    Can you give me the download for KB8881111? Most downloads i could find were full of viruses.
    Also the ethernet driver's link is dead.

  • Still same problem with audio.
    And network problem has been fixed, thank yiu.

  • edited June 2019

    If you installed the KB then the OS started to prompt you that a audio device on high definition audio bus was found, good. If not, then you'd have to slipstream the KB into your installation media with nLite and reinstall the OS (a repair install might be possible over the existing one).

    In any event, try this driver first. I've used this exact one on my workstation:

  • @win32 said:
    Now I've got some advice regarding virtualization software on Windows 2000.

    Preferably, install a program that is compatible with the vanilla OS (and with the OS identifier set to win2k), as installing newer versions under the guise of XP or 7 will confuse them, and not install services that are necessary for it to function. In fact any program that natively supports 2000 should be installed without any trickery for best results.

    In fact, I blue screened win2k when installing 7 x64 in VMware Player 3.1.2 (workstation 7.x based). Attempting to enable Aero caused it to crash and eventually corrupt the VMs (in Vista and 7), then I had problems with my mouse being unresponsive.

    How do i do that if i have kernelex installed?

  • It was more of a note to myself I made after I installed some software with the OS identifier accidentally set to XP or 7 using NNN4NT5, which comes with blackwingcat's fcwin2k package (and the "Windows 2000 Power Pack" that comes with newest kernels). For stuff like virtualizers or antivirus software which rely on device drivers, they could be installing ones very, very incompatible with Windows 2000 and could destabilize the OS.

    NNN4NT5 is for cases when installers are bootstrapped in that the installer loads another installer and they both check the OS version. Things can get messy if you forget to reset it back to 2000 SP4 and try to install OS components or anything that relies on device drivers.

  • edited July 2019

    One weird thing popped up today. Seems that if I try to load any SSL sites in Internet Explorer (like Google), they won't work anymore. Same thing happens when trying to load my e-mail in Outlook. Yet, I can still load my e-mail under Windows 95, also in Outlook 2000.

    Edit: Updating the extended kernel to 3.0b fixed the issue.

    I believe installing Visual Studio 6 may have caused the problem. That's the only change I had made to the system.

  • I failed to mention the prerequisites for running Adobe CS5/6 installers. I was befuddled for awhile because I tried to run it, failed and discovered my previous notes in this thread lacked these important details.

    Turns out that .NET Framework 3.5 and the VC++ 2008 runtime are required in addition to setting NNN4NT5 to report the OS as 7 SP1.

    Damn this thread is messy!

  • @win32 said:
    I failed to mention the prerequisites for running Adobe CS5/6 installers. I was befuddled for awhile because I tried to run it, failed and discovered my previous notes in this thread lacked these important details.

    Turns out that .NET Framework 3.5 and the VC++ 2008 runtime are required in addition to setting NNN4NT5 to report the OS as 7 SP1.

    Damn this thread is messy!

    I installed Photoshop CS5.1 Extended the other day and set the OS version in NNN4NT5 to Windows XP SP3. Then once it installed, I set it back to Windows 2000 and used FCWIN to save the OS version for just that application to Windows XP SP3. Runs like a charm now. I don't think I have .net 3.5 installed (at least, I don't see it in Add/Remove Programs)...

  • edited July 2019

    Hmm... from what I remember I couldn't get the installers to run with only .NET 2.0 SP2 and before installing VC++ 2008 the file copying process was blocked by an "lack of administrative privileges error".

    It is kinda weird because they don't need .NET on XP (or possibly 1.1, which comes with XP SP2/3). Maybe there's some common control in the package that enables it to run. Do you have any other update packages from BWC?

  • I did have VC++ 2008 installed because it came bundled with, but according to the registry and Add/Remove Programs, I only have .net 2.0 SP1. I wonder if we have different installers or something.

  • edited July 2019

    That would be strange for the CS5.5 installer to work in a case where CS5 and CS6's don't work. I don't have it on hand but I've looked at some screenshots of it and it appears to be identical to CS5.

    Since I've installed those two things, I have also gotten the Office 2010 installer to run. However, with everything in the Professional Plus package checked, it fails at a certain point. Unchecking Microsoft Groove on win2k is necessary for Office 2007 to install, but unchecking its successor (SharePoint Workspace) doesn't help here either.

  • edited July 2019

    An attempt to replace the NTVDM/WOW32 subsystem with the far superior one from Windows Server 2003 SP2 (which is the same one from XP) has failed due to missing functions in ntdll.dll and apphelp.dll.

    I'll be back for you, XP. We already got your device manager and your wannacry patches, now you will lose tie in the native DOS/win16 compatibility battle :p

  • Here's an odd one. I'm trying to install Windows 2000 on a Dell OptiPlex 790 I purchased at a surplus sale a while back. I tried the Realtek audio driver you mentioned above and it only sort of worked. If I plug in headphones, the Realtek control panel pops up and asks me what I've plugged in, like it's supposed to. I can even play some of the 3D sound tests through the headphones. However, the Windows control panel says there are no audio devices available. There's also a second listing for "Realtek High Definition Audio" in the Device Manager with a yellow bang next to it, and it says "The device cannot start".

    I wonder if this is some weird Dell-specific implementation of the Realtek ALC269Q and that's why none of the drivers I've tried have worked correctly.

  • Thanks, that got rid of the second yellow bang, but it still says no devices available. I just looked and noticed the Windows Audio service is missing. Now to figure out how to get it back...

  • The Windows Audio service was introduced in XP.

    That is weird. First video capture in virtualdub 1.10.4 craps out on my win2k laptop then this...

    Did you install USP 5.1? I know that the hotfix that introduces HDA support to Windows 2000, KB888111, must be slipstreamed or installed before the USP. I'm not sure if this issue applies to SP4 UR1, but I don't think so.

  • edited July 2019

    Whoops, you're right. I just realized that it was introduced after...

    I did use USP 5.1, but KB888111 appeared to have installed correctly, as I got the "Audio Device on High Definition Audio Bus" in the Device Manager before I installed the drivers. Perhaps that is the issue, though.

    What happened with virtualdub?

  • edited July 2019

    This happened on my ThinkPad T60 with Mobility Radeon X1300.

    I hooked up some old V-Gear webcam, which allowed me to capture video through the supplied software (which is actually Microsoft's AMCAP for Video for Windows-compatible video capture devices). Trying the same thing in virtualdub caused the OS to bluescreen with a non-descript message about hardware. This would happen even when trying to capture the desktop, where obviously the webcam isn't involved.

    I installed the extended core because I thought the drivers were made with XP in mind (and 2000 as an afterthought), but it would bluescreen with an unhandled kernel-mode exception, even when trying to launch AMCAP.

    In the end, I installed Server 2003 Enterprise Edition (faster than XP x86) which allows me to use virtualdub for capture without issue.

    Going back to your issue, maybe the generic placeholder driver is conflicting with the real one. Try disabling that one.

  • Well that didn't work. I also tried starting out fresh and installing KB8888111 before USP 5.1 but I'm stuck at the same exact issue. I even tried another audio card (SoundBlaster Audigy 2) but Windows wouldn't accept it either, though it too said "the device is working properly" in the device manager. Something has to be breaking it. Now just to figure out what...

  • edited August 2019

    Are you running PAE with > 4 GB RAM? If so, I'd like to note that Creative drivers don't like being pushed into memory addresses above 4 GB; at least in the case of the X-Fi but I wouldn't be surprised if it were the same for their other products. Realtek drivers do usually work with full PAE though.

    Try running without PAE.

  • edited August 2019

    No PAE yet. I figured I'd try to get everything working before messing around with that. The system only has 4GB RAM in it anyway. I'm setting up a VM now to try and see if maybe the SP5.1 is breaking it, or something else.

  • The only known flaw with USP 5.1, alongside the KB888111 issue is buggy USB 1.1 drivers. I never paid much attention to that due to a lack of USB 1.1-only hardware.

    I'm surprised by the broken Realtek implementation (though Dell is one to be nonconforming sometimes). You should try the extended core and install Dell's XP drivers.

  • I was using Extended Core. That's the only way I was able to get most things working (actually everything worked except the audio). Dell's XP drivers caused a BSoD.

    It's just weird that neither card worked. The SoundBlaster card had native 2000 drivers, which is what makes me think that something is being corrupted somewhere (possibly something with extended core or the USP5.1). I haven't had much of a chance to mess with it today, unfortunately.

  • Aha! Audio has been fixed :) Turns out I was using only v14 of the extended core, when there was a v16 available. Blackwingcat must have fixed that issue at some point.

  • I also have a little discovery that a friend on another forum discovered, for those who plan to use multiple monitors with win2k. v16a of the extended core is the latest version in English, but multi-monitor support is broken; but you can copy the videoprt.sys from the Japanese v16d and it works again as well!

  • Type your comment> @win32 said:

    Beware that the latest version of the Windows 2000 extended kernel, v2.9bG may create a corrupted riched20.dll dated July 2015. The WordPad/RTF engine relies on it, and many Windows Installers will fail when tasked with displaying an EULA (error code 2894).

    You should expand and transplant riched20.dll from SP5.1 installation media, dated November 2006.

    This just happened to me with v3.0b as well. The version I have in USP5.1 is dated April 2005, not November 2006. Replacing it also didn't seem to clear error 2894.

  • The version from XP SP3 (April 2008) also works.

Sign In or Register to comment.