[Offer] Microsoft PowerPoint 1.0.1

I have the first release of PowerPoint from after Microsoft's acquisition of Forethought.

As far as I know, it's exactly the same as 1.0, but all the Forethought logos and company information has been replaced by that of Microsoft.

I have Disk Copy 4.2 images of the floppy disks.

Would there be interest in me adding this to WinWorld, and if so, how do I go about this (I'm a newbie)?

PS I have quite an extensive retro Macintosh software collection archived to disk images and I'm happy to add anything else or make a list of what I have that I think WinWorld may be missing


  • Absolutely, that is one we have been looking for.

    We don't have an automatic upload system, so contributions need to be placed on a file host like dropbox, google drive, or mega. You can post a link here on the forum, or send me a Private Message with a link, if you prefer. You can also upload to Archive.org or Vetusware and send a link, we don't compete against anyone - our goal is to preserve this information in as many places as possible.

    Please include any available readable scans/photos of the disk labels.

    If you have anything else that is not posted, or even have better/more complete redumps that would be very welcome.

    Do note that I am very short on time right now, so processing things could take a while.

  • Great, I'll get on with that ASAP (I am also short on time often!).

    I'll have a look through my archives and compare with that on here for anything else that could be good.

  • edited November 2019

    Here's the link to download the disk images and (not very good) photos of the box and disks: https://www.dropbox.com/s/blxcn260hg9ahy4/Microsoft PowerPoint 1.0.1.zip?dl=0

    (link expires in 30 days)

  • Microsoft had acquired another company of the past? Doesn't surprise me, when I knew they did that for Connectix to make Virtual PC years after. I've downloaded this and will try it out to see what it's like, even though I've barely used PowerPoint in my life :P

  • Thanks. At a glance, I can't get it to run in VMAC, Basillisk, or PCE-Macplus. It crashes before the program starts.

    I am wondering if perhaps this is copy protected? What did you use to image it? If you used a real Mac, did you verify that a duplicate ran?

  • @SomeGuy said:
    I am wondering if perhaps this is copy protected?

    I believe so for me, because when I was about to unzip it, I was told that the entire archive was encrypted. I managed to get it unzipped anyhow. Not sure if the two terms are actually related, so pardon my ignorance if so.

  • @Bry89 said:
    I believe so for me, because when I was about to unzip it, I was told that the entire archive was encrypted. I managed to get it unzipped anyhow. Not sure if the two terms are actually related, so pardon my ignorance if so.

    What did you unzip with? I used Unarchiver.app and it just asked for the character set because of the "™" symbol used – choose UTF-8 here. There was no encryption.

  • @SoftWitch said:
    What did you unzip with? I used Unarchiver.app and it just asked for the character set because of the "™" symbol used – choose UTF-8 here. There was no encryption.

    It was just an ordinary .zip folder. From what you said, it seems that File Explorer somehow recognised that symbol as a sign of encryption. Strange...

  • I imaged the disks into DiskCopy 4.2 format using Disk Dup Pro on a 'real' Macintosh (a Quadra 700) running system 7.5.5.

    I then zipped the archive using Mac OS X's in-built archiver. Maybe that messed things up?

    Happy to do differently - open to suggestions.

  • I'll also test run it now - I don't recall if I did that!

  • If it is copy protected, the only proper way to dump it would be with a Kryoflux or SuperCard Pro and a Teac 3.5" Floppy drive. (most other drive brands choke on Apple's variable bitrate GCR encoding).

    Does the documentation say anything about copy protection, or the ability to make a backup copy? I kind of thought MS gave up on copy protection by the time this rolled out.

    I kind of doubt the zip tool would be to blame, but that talk about character encoding does make me think that "helpfully" converting a few kinds of characters could cause that sort of corruption. It wouldn't hurt to try a different tool - and perhaps renaming the IMG file to exclude that "TM" character.

    BTW, when I extract disk1 on my machine I get an sha 1 sum of "40e0cabb2e90f756d0711bf4138041b76d352528"

    If you test running the program, make sure the disk is write protected.

  • OK - thanks for the advice. I'll give it a test later today

  • Oh dear this is a bit embarrassing but I went back to the original disk and I get the same errors trying to run the PowerPoint program. I was convinced I'd tested it first but clearly not!

    I've carefully examined the surface of the disk under a strong light and I can see a few light stains on it that are probably the issue.

    Anyone got good tips for carefully cleaning the surface of the disk? I know they're very sensitive so I don't want to mess it up!

  • Also if using a KryoFlux would mean I didn't have to clean the disk I'd happily invest in one when they are available again in December. Can anyone with experience of using a KryoFlux tell me whether that is an option instead of cleaning disks?

  • A dirty disk is a dirty disk, kryoflux won’t fix that. When using the format guided dumps it does do retries on bad sectors, which might help, but other software can do this too. If you do the regular stream copy, it will probably be worse with a dirty disk because it doesn’t care what it’s reading.

  • OK - useful to know - thank you.

    Any tips on cleaning?

  • 3.5” disks are very tricky to clean.

    Normally, just a q-tip and water. If there is tough sticky stuff then a q-tip and 90% isopropyl alcohol – but do not use alcohol if there are scratches or shedding.

    In severe cases, running hot water in to the plastic shell may be required. But drying can be tricky.


    In this case, you were able to make a disk image and read the files OK. If there had been a readability problem, it would have told you there was an error reading from the disk. So I believe this is not a readability problem.

    Could you check the manual and see if it says anything about copy protection or the ability to back up the disk?

    What kind of Mac did you try running it on?

    I’m beginning to think either there is some subtle requirement that we are all getting wrong, or the previous user wrote bad contents back to the disk somehow.

  • There's definitely no copy protection. The manual suggests backing up the disks before even running the programs.

    I tried it on a Quadra 700 with 7.5.5, an SE/30 with 7.1, and in Mini vMac running 7.1. Crashed in all.

    I can dig out a Macintosh with a 68000 running 6.x - could be incompatible with later systems or CPUs.

    I'll try that next, before attempting any kind of cleaning - thank you for the guidance.

  • I'm not an expert on Mac stuff, but considering PowerPoint came out in 1987, System 7 seems like it may be incompatible with it. Perhaps System 5 or 6 would work better. Just a guess of mine of course.

  • edited November 2019

    I tried it in System 6 on a Macintosh Plus and it crashed part way through launching.

    I've just tried it now in Mini vMac again - this time booting from the PP disk itself - it has System 3.2 (with Finder 5.3). Launching the program again results in a full system crash :disappointed:

    According to http://www.macwizard.com/errors.html this is the error:

    ID=03 Illegal Instruction
    The computer has a specific vocabulary of machine language instructions it can understand. If a computer tries to execute an instruction that isn't in its vocabulary, you see this error code. It's less likely than error 02, but still very common.

    Unfortunately I can't test with real 68000 hardware older than a Macintosh Plus as it's all in storage, but seeing as PP came out in 1987 I figure it would have been written to run on a Plus.

    I'm fairly sure the application file itself is damaged somehow. The packaging and disks are marked "Not for resale" - could they be pre-release and there is a bug? Perhaps introduced when swapping all the Forethought info over to Microsoft info from release 1.0 to release 1.0.1?

    If so perhaps a bit of work with a hex editor would fix it? Seems like this could be turning into more of a project than I was prepared for...!

  • I did try to take a look at the binary, and compared it to Forethought PowerPoint 1.00 but since I am not familiar with the format, nothing stood out. The two are about the same size, but the internal order of stuff is different.

    At this point, I'm also thinking the application file itself is damaged somehow.

    Typically Microsoft's "not for resale" versions contain the exact same software, the only difference is they slapped on a sticker. These were often given to dealers, reviewers, or as promotional items. Even if it were a demo or limited in some way, it should still run.

    I've tried it under numerous different early MacOS versions under VMAC and PCE, with no luck. One would expect that it would run under the system version placed (possibly by the original user) on the disk.

    The error seems to occur right when it finishes loading and starts running.

    It still seems odd. The only explanation left seems to be that the original user messed it up somehow, but I don't see anything that might hint as to what happened. I did check with a virus scanner, it said everything was OK. I checked with Norton Utilities, and it did find some minor allocation error, but fixing that did not fix the program.

  • Maybe yopu need to pull some memory from your system? Old software often have memory-related bugs where too much memory leads to crashes...

  • edited November 2019

    @SomeGuy that's very extensive - all the things I would have tried too - thank you.

    I can't think of anything else to try at this point.

    I do have some friends who could help me poke at the binary and know a lot more about software than I do. I may see if they're up for a bit of a challenge!

Sign In or Register to comment.